Child element with "position:absolute" don't see "position:relative" in parent if parent has "display:table-cell"

RESOLVED DUPLICATE of bug 63895

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 63895
5 years ago
5 years ago

People

(Reporter: grigorchuk, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-Chrome], [parity-Opera], [parity-IE], [parity-safari])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

I nest element with "position:absolute" to element with "position:relative" and "display:table-cell" 


Actual results:

Child element with "position:absolute" calculates its position relatively to the whole document 


Expected results:

Child element with "position:absolute" must calculate it's position relatively to parent element. You can see whole case in http://jsfiddle.net/NaJ4a/15/ 
Child element is div.arrow

Comment 1

5 years ago
See http://www.w3.org/TR/CSS2/visuren.html#propdef-position

"The effect of 'position:relative' on table-row-group, table-header-group, table-footer-group, table-row, table-column-group, table-column, table-cell, and table-caption elements is undefined. "

So I think this is INVALID.
(Reporter)

Comment 2

5 years ago
The fact is that all other browsers DEFINE it as usual "position:relative" effect. Even IE7.

Comment 3

5 years ago
Indeed, `position:relative` for table cells does work in _all_ browsers (IE, Chrome, Safari, Opera) except Firefox. So it's nothing useful in ignoring this in Firefox only.

This is quite similar to bug 87277 which has lead to nothing else than web-developers' frustration and unreasonable efforts to workaround it and eventually has been fixed anyway -- just after years of useless waiting.

Thanks.

Updated

5 years ago
Component: Untriaged → Layout
Product: Firefox → Core

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [parity-Chrome], [parity-Opera], [parity-IE], [parity-safari]
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 63895
You need to log in before you can comment on or make changes to this bug.