Closed Bug 804000 Opened 8 years ago Closed 7 years ago

images sometimes don't show up on facebook

Categories

(Core :: ImageLib, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 802390

People

(Reporter: tnikkel, Assigned: jrmuizel)

References

Details

Some images don't show up on facebook some of the time. No STR. This started happening recently. Based on the time I would suspect bug 505385.
When you say "don't show up", can you be more specific?
There is a blank white space of the correct size where they should be.
I don't expect that you'll spend any time investigating this, just thought that maybe you knew of one of the followup fixes or open regression bugs might cover this already.
I will also sometimes see both the image drawn and what seems to be the alt text for the image.

Loading the page again, or loading a different page that has the same image will show the same problem.
The 2012-10-14 nightly has the bug, testing 2012-10-13 now it hasn't shown up yet. Bug 505385 is in 2012-10-14 but not in 2012-10-13. I want to test 2012-10-13 some more still to be more confident.
Update the 2012-10-13 and 2012-10-12 nightlies show the problem for me as well, so bug 505385 is off the hook.
Looks like 2012-10-06 has the problem, 2012-10-02 does not have the problem.
regression range
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fd724f194a1f&tochange=9f677c2bb33d

http://hg.mozilla.org/mozilla-central/rev/68dd2bcc51ee or bug 792199 is the one that stands out in there.

I'm still seeing this with a 2012-11-01 nightly.
And this change to trunk seems to fix the problem for me:
 NS_IMETHODIMP
 RasterImage::RequestDecode()
 {
-  return RequestDecodeCore(ASYNCHRONOUS);
+  return RequestDecodeCore(SOMEWHAT_SYNCHRONOUS);
 }
Blocks: 792199
And the opposite change, making it always async:

 RasterImage::StartDecoding()
 {
-  return RequestDecodeCore(SOMEWHAT_SYNCHRONOUS);
+  return RequestDecodeCore(ASYNCHRONOUS);
 }

turns the turn quite orange:
https://tbpl.mozilla.org/?tree=Try&rev=34afa5ad07e0
which I don't think is something we want.
I'll try to look at this today.
Assignee: nobody → jmuizelaar
I think the patch from bug 802390 should fix this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 802390
Bug 802390 is tracking 19.
You need to log in before you can comment on or make changes to this bug.