imgur.com "original" (non-mobile) uploader triggers "Well, this is embarrassing. We tried to display this webpage, but it's not responding."

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dholbert, Assigned: baku)

Tracking

({b2g-testdriver, unagi})

unspecified
x86_64
Linux
b2g-testdriver, unagi
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
STR:
 1. Visit http://imgur.com/?original in the B2G browser.
 2. Once the "Computer | Web" buttons are visible (under "Upload images"), hit the "Computer" button

ACTUAL RESULTS:
 Page immediately changes to a gray special-page saying:
> Well, this is embarrassing.
>
>  [sad icon]
>
> We tried to display this webpage, but
> it's not responding.
(Reporter)

Comment 1

6 years ago
That "embarrassing" page also has buttons at the bottom:
 [Close Tab]  [Reload]

Reload seems to work, but Close Tab does not. (it has no effect, if that's the only tab.  Or -- if you have additional tabs open, it blanks the screen but does not close the tab.)
(Reporter)

Comment 2

6 years ago
Created attachment 673981 [details]
screenshot
Thanks for reporting this. There are a few issues here:

1. The "Close Tab" button doesn't work. This button shouldn't be displayed if there is only one tab open, this should be fixed in a more recent build under bug 797272
2. The browser displays a crash screen. The browser app is correctly responding to a fatal error event received because the content process of the tab has crashed.
3. The content process crashes. It looks like this is caused by trying to pick a file using an input type="file" element. This is an unsupported feature in v1 but I think that it causing a process crash may be a regression.

Moving this to the general Boot2Gecko component so that the cause of the crash can be investigated further.
Component: Gaia::Browser → General
Bug 801635 is about implementing a filepicker. So that will ensure that we're not crashing.

Marking as dependent so that we check that this doesn't crash once that bug is fixed.
Assignee: nobody → amarchesini
blocking-basecamp: --- → +
Depends on: 801635
This bug is set as blocking-basecamp+, but is blocked by bug 801635 which is marked as blocking-basecamp-

Support for file uploads was dropped as a v1 requirement a month ago in bug 796384

Although it would be great not to have this limitation, we are past feature freeze and this seems like feature work which hasn't had driver approval.

Would a bug fix which prevents this from crashing the content process be enough?
Yup, a patch which fixes the crash would definitely be enough to fix this bug.
(Assignee)

Comment 7

6 years ago
Created attachment 680130 [details] [diff] [review]
patch

This patch removes the nsFilePicker from the manifest.
This seems enough to fix the bug.
Attachment #680130 - Flags: review?(fabrice)
(Assignee)

Updated

6 years ago
Attachment #680130 - Attachment is patch: true
(Assignee)

Comment 8

6 years ago
Created attachment 680159 [details] [diff] [review]
patch
Attachment #680130 - Attachment is obsolete: true
Attachment #680130 - Flags: review?(fabrice)
Attachment #680159 - Flags: review?(fabrice)
Attachment #680159 - Flags: review?(fabrice) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e57d9d6a66ae
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/34c4f8b76f49
status-firefox18: --- → fixed
status-firefox19: --- → fixed
Depends on: 832923
You need to log in before you can comment on or make changes to this bug.