Last Comment Bug 804411 - JavaScript has to be enabled to parse feeds
: JavaScript has to be enabled to parse feeds
Status: RESOLVED FIXED
: regression
Product: SeaMonkey
Classification: Client Software
Component: Feed Discovery and Preview (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on: 786009
Blocks: 774585
  Show dependency treegraph
 
Reported: 2012-10-22 17:24 PDT by neil@parkwaycc.co.uk
Modified: 2012-10-31 13:20 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
unaffected
fixed
fixed
fixed


Attachments
Proposed patch (1.63 KB, patch)
2012-10-23 16:33 PDT, neil@parkwaycc.co.uk
iann_bugzilla: review+
iann_bugzilla: approval‑comm‑aurora+
iann_bugzilla: approval‑comm‑beta+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2012-10-22 17:24:30 PDT
Steps to reproduce problem:
1) disable JavaScript in browser
2) open: http://www.irregularwebcomic.net/rss3.xml

Actual result: feed doesn't get parsed.

Expected result: feed should be displayed.

Additional information: This bug was created as a clone of bug 786009.
Comment 1 therube 2012-10-22 17:45:43 PDT
Confirmed.

2.13.1 works properly.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20121011 Firefox/16.0 SeaMonkey/2.13.1
Build identifier: 20121011080919

By the time we reach here we're broken:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1
Build identifier: 20120726003003

In that case, no page actually loads.  It shows "done", but the page is entirely gray, & Page Info shows it to be about:blank.

Error Console shows:

Error: Services.scriptSecurityManager.getCodebasePrincipal is not a function
Source File: resource:///components/nsAbout.js
Line: 43

I did see this, once:

Error: Search service falling back to synchronous initialization at SRCH_SVC__ensureInitialized@resource:///components/nsSearchService.js:2498
@resource:///components/nsSearchService.js:3468
@chrome://communicator/content/nsContextMenu.js:1284
@chrome://communicator/content/nsContextMenu.js:45
nsContextMenu@chrome://communicator/content/nsContextMenu.js:26
onpopupshowing@chrome://navigator/content/navigator.xul:1

Source File: resource:///components/nsSearchService.js
Line: 2499

A later build is different again, actually loading the page, though not displaying its data, & no Error Console message:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1
Build identifier: 20120814003006

(these are builds I had on hand, so can't necessarily give a precise regression range)
Comment 2 neil@parkwaycc.co.uk 2012-10-23 01:15:48 PDT
(In reply to therube from comment #1)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
> SeaMonkey/2.14a1
> Build identifier: 20120726003003
> 
> In that case, no page actually loads.  It shows "done", but the page is
> entirely gray, & Page Info shows it to be about:blank.
> 
> Error Console shows:
> 
> Error: Services.scriptSecurityManager.getCodebasePrincipal is not a function
> Source File: resource:///components/nsAbout.js
> Line: 43
This was fixed later on in the 2.14 cycle, so 2.14b doesn't throw this error.
Comment 3 neil@parkwaycc.co.uk 2012-10-23 05:42:13 PDT
Well, there appear to be a number of options:

1. Restore nsAboutFeeds.js and add the custom principal there
2. Always add the custom principal in nsAbout.js
   (I tried this and I couldn't get anything to break)
3. Add a special case for about:feeds in nsAbout.js
4. Add a special case for about:feeds in nsAbout.js BUT
   hide it under its own flag
Comment 4 neil@parkwaycc.co.uk 2012-10-23 05:49:13 PDT
5. Add the custom principal in FeedConverter.js
Comment 5 neil@parkwaycc.co.uk 2012-10-23 16:33:21 PDT
Created attachment 674441 [details] [diff] [review]
Proposed patch
Comment 6 neil@parkwaycc.co.uk 2012-10-27 07:17:13 PDT
Pushed comm-central changeset 0e457d4ab692.
Comment 7 neil@parkwaycc.co.uk 2012-10-27 07:20:36 PDT
Comment on attachment 674441 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 774585
User impact if declined: Unable to view feeds when JavaScript is disabled
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None

Note You need to log in before you can comment on or make changes to this bug.