Authentication not passed to Proxy Server (Firefox 17.0 beta)

RESOLVED DUPLICATE of bug 785050

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 785050
5 years ago
5 years ago

People

(Reporter: Tom, Assigned: mcmanus)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)

Steps to reproduce:

Summary: Upgraded from Firefox 16.0.1 to 17.0 beta.

Detail: Firefox 16.0.1 loaded external websites fine.  Under Tools > Options > Advanced > Network > Connection > Settings, "Use system proxy settings" worked fine.  OS (Windows 7 Professional, 6.1 build 7601 SP 1) had System Internet Options using an automatic proxy - System Internet Options -> Connections -> LAN Settings -> Use automatic configuration script.  URL was http://<local_server>/<local_path>/<local_file>.pac

I then upgraded to 17.0 beta.  Under Tools > Options > Advanced > Network > Connection > Settings, "Use system proxy settings" was still selected and no configuration was changed, but no the browser no longer loads websites through the proxy server.  Local servers (which don't use the proxy server) load fine.  Details of error in next box.

This is reproducable.  If I install 16.0.1, then proxy works again.  If I then install 17.0 beta again, it breaks as above.  If I change Firefox to use an automatic script and point to the same URL as IE, exactly the same behaviour is seen (works in 16.0.1, same error seen in 17.0 beta).


Actual results:

Summary: Received a 407 proxy authenatication error.

Detail: When trying to load http://www.google.co.uk/ I get the following error (I replaced the local server name with <local_server>:

 	Explanation: There is a problem with the page you are trying to reach and it cannot be displayed.

Try the following:

    Refresh page: Search for the page again by clicking the Refresh button. The timeout may have occurred due to Internet congestion.
    Check spelling: Check that you typed the Web page address correctly. The address may have been mistyped.
    Access from a link: If there is a link to the page you are looking for, try accessing the page from that link. 

If you are still not able to view the requested page, try contacting your administrator or Helpdesk.

	Technical Information (for support personnel)

    Error Code: 407 Proxy Authentication Required. The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. (12209)
    IP Address: 10.169.12.71
    Date: 23/10/2012 13:35:53 [GMT]
    Server: <local_server>
    Source: proxy 


Expected results:

Webpage should have loaded, as with 16.0.1.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 804573
Component: Untriaged → Networking
Product: Firefox → Core
(Assignee)

Updated

5 years ago
Assignee: nobody → mcmanus
(Assignee)

Comment 2

5 years ago
I suspect this is a dup of bug 785050 which is fixed on 17 beta 3, but is a problem in 17 beta 2. You filed it on 10/23 which was also release day for beta 3, so its hard to know what you were probably running.

Can you check for updates and confirm you are on beta 3 and then retest?

I believe if you go to about:buildconfig beta3 should have a line under source that says

Built from http://hg.mozilla.org/releases/mozilla-beta/rev/957d1e48ef80
Flags: needinfo?(y2n7m2aw3w)
(Assignee)

Comment 3

5 years ago
I actually just clicked the check for update on a windows beta build and it was happy to let me stay at beta 2.. I don't know why that is (I'm not involved in day 2 day ops of the distribution channels).

but I do know that you can download 17 beta 3 from here:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/17.0b3-candidates/build1/win32/en-US/
(Reporter)

Comment 4

5 years ago
Yes, looks like I had installed beta 2 because the install executable was named "Firefox Setup 17.0b2.exe"

about:buildconfig reports "Built from http://hg.mozilla.org/releases/mozilla-beta/rev/2ba4becf6e35" (without quotes)

Just installed beta 3 and it seems to be fixed, so I am now marking this resolved.

Thank you all!
Flags: needinfo?(y2n7m2aw3w)
(Reporter)

Comment 5

5 years ago
Marked as duplicate of 785050
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785050
You need to log in before you can comment on or make changes to this bug.