Closed Bug 804580 Opened 9 years ago Closed 8 years ago

Click-to-play doesn't work with QuickTime videos

Categories

(Core :: Plug-ins, defect, P3)

x86_64
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 752516

People

(Reporter: pauly, Unassigned)

References

Details

(Whiteboard: not a FF17/CTP blocklisting issue)

STR:
1. Set the plugins.click_to_play pref on TRUE in about:config
2. Open http://trailers.apple.com/trailers/marvel/ironman3/
3. Click to activate the QuickTime plugin

Actual results:
The video won't play

Expected results:
The video should start playing

Note: If activating the plugin from the doorhanger near the location bar, the video will start playing.
This is not a regression.
Whiteboard: not a FF17/CTP blocklisting issue
Priority: -- → P3
I just encountered this issue, and it's not a quicktime problem, it's a trailers.apple.com problem.  The media controls at the bottom of the video are contained in a <div> that also covers the video and captures the pointer. pointer-events:none; on the <div> fixes it (with pointer-events:auto; for it's children so the controls still work).

Dupe of bug 752516
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752516
Duplicate of this bug: 932666
You need to log in before you can comment on or make changes to this bug.