Closed Bug 804613 Opened 7 years ago Closed 7 years ago

crash in DocumentViewerImpl::~DocumentViewerImpl()

Categories

(Core :: Layout, defect, critical)

19 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: kairo, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-e7298ccd-e548-47e2-97f7-18bf02121023 .
============================================================= 

This crash signature was present at extremely low volume in previous releases, apparently, but it exploded on trunk on 2012-10-18, so something checked in on the day before caused this regression. This is topcrash #8 over the last 3 days now.

See https://crash-stats.mozilla.com/report/list?signature=DocumentViewerImpl%3A%3A~DocumentViewerImpl%28%29 for more reports.
It happens only in 64-bit builds.
OS: Windows NT → Windows 7
Hardware: All → x86_64
A quick look at addon correlations did not turn up anything interesting - looking at module correlations next.
(In reply to David Baron [:dbaron] from comment #3)
> Based on the sharpness of the regression in terms of build date it certainly
> looks like a regression on our end.
...that is likely tracked by another bug based on 32-bit signatures, indeed 64-bit stack traces are usually buggy and can't be connected to 32-bit stack traces.
This stack trace looks perfectly reasonable.

But:  do we run correlation data at all for Win64?  I'm not sure if we do.
There's only one crash in 19.0a1/20121023 likely almost fixed by bug 802485.
(In reply to Scoobidiver from comment #6)
> There's only one crash in 19.0a1/20121023
I don't even find it.
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: regression
Resolution: --- → WORKSFORME
Version: Trunk → 19 Branch
You need to log in before you can comment on or make changes to this bug.