Closed Bug 804644 Opened 7 years ago Closed 7 years ago

some form controls are scaled too aggressively during full-page zoom

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 + fixed
firefox19 + fixed

People

(Reporter: jfkthame, Assigned: jfkthame)

References

()

Details

Attachments

(2 files)

When zooming the page in or out, some form controls (those whose size is based on a system font size) are scaled over-aggressively, causing them to appear out of proportion to the rest of the page content. See the testcase in URL field, and zoom in several steps. (Screenshot attached showing the result.)

This is a result of patch 4 in bug 674373, which modified how system font sizes are looked up, so that the value can be returned in device pixels. The problem is that the conversion to device pixels is affected by page zoom, which it shouldn't be; we want the unzoomed pixel size for styling purposes, as zoom will subsequently be applied to all the content.
This fixes the incorrect zoom behavior, by using the unscaled device pixel ratio when converting Cocoa points to device-pixel font sizes.
Attachment #674261 - Flags: review?(roc)
Attachment #674261 - Attachment description: form-control-scaling try: -b d -p linux,macosx64,win32 -u all → patch, convert Cocoa points to _unscaled_ device pixels for system font sizes
https://hg.mozilla.org/mozilla-central/rev/38ae29192358
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Comment on attachment 674261 [details] [diff] [review]
patch, convert Cocoa points to _unscaled_ device pixels for system font sizes

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 674373 (HiDPI support)

User impact if declined: ugly/broken results on zoomed pages with form controls

Testing completed (on m-c, etc.): confirmed to fix the problem in local testing; landed on inbound/m-c without problems

Risk to taking this patch (and alternatives if risky): minimal risk, just corrects font size scaling factor used on OS X

String or UUID changes made by this patch: none
Attachment #674261 - Flags: approval-mozilla-aurora?
Attachment #674261 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.