The default bug view has changed. See this FAQ.

Remove UI for HTTP Networking, Enable Keep-Alive, N/A Since Bug 770331

RESOLVED FIXED

Status

SeaMonkey
UI Design
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: therube, Assigned: neil@parkwaycc.co.uk)

Tracking

SeaMonkey 2.14 Branch
x86
Windows XP

SeaMonkey Tracking Flags

(seamonkey2.13 unaffected, seamonkey2.14 fixed, seamonkey2.15 fixed, seamonkey2.16 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Bug 770331 - Remove HTTP Keep-Alive disable pref, removed both the Preference & the functionality related to the Pref to disable 'Enable Keep-Alive', so having the UI is now moot.
(Reporter)

Updated

5 years ago
See Also: → bug 804618
(Assignee)

Comment 1

5 years ago
Created attachment 674431 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #674431 - Flags: review?(iann_bugzilla)

Comment 2

5 years ago
Comment on attachment 674431 [details] [diff] [review]
Proposed patch

Could you also remove the relevant section from the help too
http://mxr.mozilla.org/comm-central/source/suite/locales/en-US/chrome/common/help/cs_nav_prefs_advanced.xhtml#412
r=me with that fixed.
Attachment #674431 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 3

5 years ago
Pushed comm-central changeset 1789fa3d0540.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

5 years ago
Created attachment 675842 [details] [diff] [review]
Branch-safe version

[Approval Request Comment]
Regression caused by (bug #): 770331
User impact if declined: Pref panel behaves incorrectly
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: Help file entry removed. DTD entity removals were removed from this patch.
Attachment #675842 - Flags: approval-comm-beta?
Attachment #675842 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #675842 - Flags: review+
Attachment #675842 - Flags: approval-comm-beta?
Attachment #675842 - Flags: approval-comm-beta+
Attachment #675842 - Flags: approval-comm-aurora?
Attachment #675842 - Flags: approval-comm-aurora+
(Assignee)

Comment 5

5 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/866b3ceec960
http://hg.mozilla.org/releases/comm-beta/rev/896eaa8b2eac
status-seamonkey2.13: --- → unaffected
status-seamonkey2.14: --- → fixed
status-seamonkey2.15: --- → fixed
status-seamonkey2.16: --- → fixed
You need to log in before you can comment on or make changes to this bug.