B2G could end up on a blurry page after zooming in on a page and then going to a link

RESOLVED FIXED in Firefox 18

Status

()

Core
Graphics
P4
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: kentuckyfriedtakahe)

Tracking

18 Branch
mozilla20
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-basecamp:-, firefox18 fixed, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(2 attachments)

Created attachment 674416 [details]
screenshot

## Environment :
Otoro phone, build 2012-10-23
Taken from default.xml in b2g-distro: 
* "platform_build" revision= db539a3bd139c93c09b0cd1c3f9396b74d68717c
* "gaia" revision= 0b8ec9b8c16429dc35453dbb7b9342fab3dd18fb 
* "releases-mozilla-aurora" revision= f58edfde05cb708f8a2c440d338f2e429aaf372b
* "gonk-misc" revision= db0c751715f4696515735eb1e0dc5df7a40eb81d

  
## Repro :
1. launch browser on b2g device
2. go to http://people.mozilla.com/~nhirata/html_tp
3. zoom in to be able to read
4. hit the parent directory at the top 

## Expected :
1. a none blurry page

## Actual :
1. blurry

## Note :
related to bug 795657?
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM

Updated

5 years ago
Duplicate of this bug: 806035
Just a quick not that this still happens in the 2012-11-28 build.
Correction: My report was for the 2012-11-27 build.
Status: NEW → ASSIGNED
QA Contact: ajones
Assignee: nobody → ajones
QA Contact: ajones
I can reproduce it using back/forward buttons.
Created attachment 688569 [details] [diff] [review]
Fixed missing reset of zoom
Attachment #688569 - Attachment description: Bug 804808 - Fixed missing reset of zoom; r=cjones → Fixed missing reset of zoom
Attachment #688569 - Flags: review?(jones.chris.g)
Comment on attachment 688569 [details] [diff] [review]
Fixed missing reset of zoom

PresShell is supposed to be doing this.  Are we not hitting that code on navigation?
Attachment #688569 - Flags: review?(jones.chris.g)
We don't hit that code using back/forward unless we are reloading the page.
Comment on attachment 688569 [details] [diff] [review]
Fixed missing reset of zoom

Right, we discussed this on IRC yesterday and I forgot to r+.  ftfy
Attachment #688569 - Flags: review+

Comment 9

5 years ago
Try run for d89aeaa26d2d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=d89aeaa26d2d
Results (out of 97 total builds):
    success: 84
    warnings: 13
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-d89aeaa26d2d

Comment 10

5 years ago
Try run for d89aeaa26d2d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=d89aeaa26d2d
Results (out of 98 total builds):
    success: 85
    warnings: 13
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-d89aeaa26d2d
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/f02032810972
Keywords: checkin-needed
Whiteboard: b2g
https://hg.mozilla.org/mozilla-central/rev/f02032810972
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
blocking-basecamp: --- → ?
Comment on attachment 688569 [details] [diff] [review]
Fixed missing reset of zoom

I don't have approval powers but I would approve this.

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
 apzc
User impact if declined:
 back/forward navigation is always messed up
Testing completed (on m-c, etc.):
 manual testing by ajones
Risk to taking this patch (and alternatives if risky):
 zero risk for non-b2g.  \epsilon risk for b2g.
String or UUID changes made by this patch:
 none
Attachment #688569 - Flags: approval-mozilla-beta?
Attachment #688569 - Flags: approval-mozilla-aurora?
Attachment #688569 - Flags: approval-mozilla-beta?
Attachment #688569 - Flags: approval-mozilla-beta+
Attachment #688569 - Flags: approval-mozilla-aurora?
Attachment #688569 - Flags: approval-mozilla-aurora+
While we should fix this (and Jonas will approve for uplift), due to the fact that this is easily worked around, we decided during triage we wouldn't block on it.
blocking-basecamp: ? → -
Priority: -- → P4
https://hg.mozilla.org/releases/mozilla-aurora/rev/711f9df3e7bb
https://hg.mozilla.org/releases/mozilla-beta/rev/660f08b60719
status-firefox18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Oh drat, existing approval-beta+'s for blocking-basecamp bugs need to be going on b2g18 now.

Alex, do you have any bugzilla ninjitsu that could help fix this?

This patch has zero risk on beta so I'll leave it there and uplift to b2g18.
https://hg.mozilla.org/releases/mozilla-b2g18/rev/fa9d493d6056
Whiteboard: [status-b2g18:fixed]
status-b2g18: --- → fixed
Whiteboard: [status-b2g18:fixed]
In the future, don't bother landing separately on b2g18 if it's already on beta. We're merging beta to b2g18 regularly anyway.
https://hg.mozilla.org/releases/mozilla-b2g18/rev/660f08b60719

Comment 19

5 years ago
Try run for 242cbc75ebd3 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=242cbc75ebd3
Results (out of 83 total builds):
    success: 57
    warnings: 25
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-242cbc75ebd3

Comment 20

5 years ago
Try run for d89aeaa26d2d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=d89aeaa26d2d
Results (out of 99 total builds):
    exception: 1
    success: 85
    warnings: 13
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-d89aeaa26d2d
You need to log in before you can comment on or make changes to this bug.