Closed Bug 804957 Opened 8 years ago Closed 8 years ago

Crash when opening from home screen an edited bookmark

Categories

(Firefox for Android :: General, defect, critical)

17 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 763813
Tracking Status
firefox17 --- affected
firefox18 --- affected
firefox19 --- affected

People

(Reporter: andreea.pod, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

Build: Firefox 17 Beta 3 (2012-10-23)
Device: Samsung Galaxy Nexus 
OS: Android 4.1.2

Steps to reproduce:
1. bookmark a page
2. go to bookmarks and edit the URL of the bookmark (e.g.:change it in to google.com)
3. add the bookmark to home screen
4. go to home screen (don't quit Firefox) and tap on the bookmark

Expected result:
- the bookmark with the new URL should open in browser

Actual result:
- Firefox crashes: https://crash-stats.mozilla.com/report/index/bp-564a7a80-7b99-4d23-98ae-203b32121024

Note: also reproducible on Nightly and Aurora from: 2012-10-23
Dupe of bug 763813?
Severity: normal → critical
Crash Signature: [@ mozalloc_abort | org.mozilla.firefox_beta-1.apk@0x1243c63]
Keywords: crash
Whiteboard: [native-crash]
This happens when the URL is malformed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763813
You need to log in before you can comment on or make changes to this bug.