Closed Bug 805032 Opened 8 years ago Closed 8 years ago

Latest esr10 nightly installer sometimes fails on Windows 2000 because it requires Windows XP SP2

Categories

(Firefox :: Installer, defect)

17 Branch
x86
Windows 2000
defect
Not set
blocker

Tracking

()

RESOLVED FIXED
Firefox 10
Tracking Status
firefox-esr10 17+ verified

People

(Reporter: whimboo, Assigned: bbondy)

References

()

Details

We have seen this issue today in one of our Mozmill CI testruns for ESR10 builds on Windows 2000. While the first builds today were working fine I can now constantly reproduce this problem. The installer claims that Windows XP with SP2 is necessary.

One of the affected testruns can be found here:
http://10.250.73.243:8080/job/mozilla-esr10_remote/343/console

When I manually download the build from FTP and run it myself I get the same problem. I have no idea why it was working before today and is failing now.

Has anything been landed lately on the esr10 branch?
Looks to me like http://hg.mozilla.org/releases/mozilla-esr10/rev/068daaf3849d is to blame, which is from bug 792106.
Depends on: CVE-2012-4206
Yes if we want to run on win2k on esr10 we'll have to revert these changesets:
https://hg.mozilla.org/releases/mozilla-esr10/rev/82648c9365f8
https://hg.mozilla.org/releases/mozilla-esr10/rev/068daaf3849d
We do need to continue supporting Win2K, so tracking for 17+.
Shall I just back them out now? I'm not sure what the process is for this.
hg backout 82648c9365f8
hg backout 068daaf3849d
https://hg.mozilla.org/releases/mozilla-esr10/rev/0626ed379de3

(I guess this is TM: Firefox 10?)
Assignee: nobody → netzen
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 10
Flags: in-testsuite-
Depends on: 811557
Keywords: verifyme
Verified that Firefox 10.0.11 ESR can be installed on Windows 2000. The message that the 'Microsoft Windows XP SP2 or newer is required' is not displayed when installing it.
Thanks Simona.

We should retest this if the patches currently waiting approval in bug 792106 get uplifted to esr10.
No longer depends on: 811557
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.