Cursor is moving to the left during entering numbers in web page form fields

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: stephan, Unassigned)

Tracking

16 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

I'm entering a number code into a text field of my online banking web page.


Actual results:

After entering the second digit, the cursor is juming one position back to the left direction. Then when I entering the 3rd and following digits the appear at the wrong position inside the number string.


Expected results:

I't obiously clear that the consequtive entering of number should generate a string of numbers in the same order of entering.
Can you try Nightly for Android and report back if that works for you? (http://nightly.mozilla.org)
OS: Windows 7 → Android
Hardware: x86_64 → ARM

Comment 2

7 years ago
I can reproduce this while using nightly on a nexus 7 on 4.12 . (4.1.2) in fact it just did it.
Reporter

Comment 3

7 years ago
With the nightly build from Oct. 29, I can reproduce this bug. On the Asus TF700T.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Can you try again with the latest nightly? Thanks.
Reporter

Comment 5

7 years ago
I tested version 19.0a1 (2012-11-06). I cannot reproduce the bad behavior anymore. 
Number input feels like it should.
Good job.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.