Stop calling NotifyPull on finished streams

RESOLVED FIXED in mozilla19

Status

()

Core
Audio/Video
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: roc, Assigned: jesup)

Tracking

18 Branch
mozilla19
x86_64
Windows 7
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 affected)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Created attachment 675513 [details] [diff] [review]
fix
Attachment #675513 - Flags: review?(rjesup)
(Assignee)

Updated

5 years ago
Attachment #675513 - Flags: review?(rjesup) → review+
(Assignee)

Updated

5 years ago
Duplicate of this bug: 802673
(Assignee)

Comment 3

5 years ago
Roc - I landed this for you, as I could really use it being in the tree ASAP.  Hope that doesn't step on your toes!

https://hg.mozilla.org/integration/mozilla-inbound/rev/029363c238ae

This probably affects 17 and 16 as well, but I haven't checked.
Assignee: roc → rjesup
status-firefox18: --- → affected
status-firefox19: --- → affected
Target Milestone: --- → mozilla19
(Assignee)

Comment 4

5 years ago
Thanks Rob; this appears to fix the video lockup problem (though we may have more fixes to make in this area to handle edge cases) (see dup)
https://hg.mozilla.org/mozilla-central/rev/029363c238ae
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED

Updated

5 years ago
status-firefox19: affected → ---
You need to log in before you can comment on or make changes to this bug.