The default bug view has changed. See this FAQ.

exclude override.ini from mac signatures

RESOLVED FIXED in Firefox 16

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

unspecified
mozilla19
Points:
---

Firefox Tracking Flags

(firefox16 fixed, firefox17 fixed, firefox18 fixed, firefox19 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Tomcat did a repack the other day that ended up breaking the signature on a build, because override.ini existed. If this is a valid change for a partner repack to make, we need to exclude this file from the signature, just as we exclude distribution/.
its caused by the setting migrationWizardDisabled=true in the repack.cfg btw
(Assignee)

Comment 2

5 years ago
Kev, can you confirm that this is a valid change to partner repacks?
Flags: needinfo?(kev)
note, that affect also the bing repacks build by the release automation

Comment 4

5 years ago
It can be a valid configuration, yes. Some orgs have chosen to disable the migration wizard with their distributions, which we've permitted.
Flags: needinfo?(kev)
(Assignee)

Comment 5

5 years ago
Thanks Kev. This is an easy fix, though we need to backport it all the way to release.
Assignee: nobody → bhearsum
(Assignee)

Comment 6

5 years ago
Created attachment 676119 [details] [diff] [review]
exclude override.ini from mac signature
Attachment #676119 - Flags: review?(ted)
Attachment #676119 - Flags: review?(ted) → review+
(Assignee)

Comment 7

5 years ago
Comment on attachment 676119 [details] [diff] [review]
exclude override.ini from mac signature

Landed on mozilla-central: https://hg.mozilla.org/mozilla-central/rev/3a7226d6429b

We should backport this all the way to release, just in case we have another point release.
Attachment #676119 - Flags: approval-mozilla-release?
Attachment #676119 - Flags: approval-mozilla-beta?
Attachment #676119 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
Created attachment 676134 [details] [diff] [review]
sync up thunderbird's CodeResources

This patch does the same for Thunderbird, and also removes extensions/ and mozilla.cfg/ like we did for Firefox. I just confirmed with kev on IRC that it's OK to do that:
10:15 < bhearsum|buildduty> so, we originally included distribution/, extensions/, and mozilla.cfg from the mac 
                            signature. then we backed out the distribution/ part, because it broke partials 
                            (because repacks modify distribution/). can partner builds modify extensions/ and/or 
                            mozilla.cfg? if so, we should probably exclude those too
10:16 < kev> distribution/extensions, but not extensions under the appdir
10:16 < kev> and mozilla.cfg is not something we typically modify
10:16 < bhearsum|buildduty> okay
10:16 < kev> heck, not typically, ever
10:16 < kev> the enterprise folks do, though
10:17 < kev> but that's a different deal and less OSX-y
10:17 < bhearsum|buildduty> sounds like we're fine as we are then, modulo excluding override.ini
10:17 < kev> yup
Attachment #676134 - Flags: review?(mbanner)
Attachment #676134 - Flags: approval-mozilla-release?
Attachment #676134 - Flags: approval-mozilla-beta?
Attachment #676134 - Flags: approval-mozilla-aurora?
Comment on attachment 676134 [details] [diff] [review]
sync up thunderbird's CodeResources

r+ as a comm-* build peer, however I can't do approvals for comm so will need mark's a+ (though technically the a-m-* flags neither of us can tweak to a +)
Attachment #676134 - Flags: review?(mbanner) → review+
(Assignee)

Comment 10

5 years ago
Comment on attachment 676134 [details] [diff] [review]
sync up thunderbird's CodeResources

Landed on comm-central. https://hg.mozilla.org/comm-central/rev/9687bde9504c
Attachment #676134 - Flags: checkin+
Comment on attachment 676119 [details] [diff] [review]
exclude override.ini from mac signature

Doubt we'll see another 16 point release, but approving for release channel regardless so we don't miss this.  Please land to default and relbranch on m-r to be sure.
Attachment #676119 - Flags: approval-mozilla-release?
Attachment #676119 - Flags: approval-mozilla-release+
Attachment #676119 - Flags: approval-mozilla-beta?
Attachment #676119 - Flags: approval-mozilla-beta+
Attachment #676119 - Flags: approval-mozilla-aurora?
Attachment #676119 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 12

5 years ago
Comment on attachment 676134 [details] [diff] [review]
sync up thunderbird's CodeResources

removing pointless flags from the patch. Mark, can you give me the OK to land this on aurora/beta/release?
Attachment #676134 - Flags: approval-mozilla-release?
Attachment #676134 - Flags: approval-mozilla-beta?
Attachment #676134 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Flags: needinfo?(mbanner)
(Assignee)

Comment 13

5 years ago
Comment on attachment 676119 [details] [diff] [review]
exclude override.ini from mac signature

aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/1c9738682796
beta: https://hg.mozilla.org/releases/mozilla-beta/rev/1d64c59bc1e5
release: https://hg.mozilla.org/releases/mozilla-release/rev/c238387bf75f
https://hg.mozilla.org/releases/mozilla-release/rev/877d95bd193f
a=me for aurora, & beta. You can land on release as well if you want, but as Thunderbird doesn't do partner repacks, I don't think it really matters.
Flags: needinfo?(mbanner) needinfo?(mbanner) → needinfo+
(Assignee)

Comment 15

5 years ago
Comment on attachment 676134 [details] [diff] [review]
sync up thunderbird's CodeResources

OK, I just landed on aurora & beta:
https://hg.mozilla.org/releases/comm-aurora/rev/6f7abd2d596c
https://hg.mozilla.org/releases/comm-beta/rev/fde1dd72ce09
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox16: --- → fixed
status-firefox17: --- → fixed
status-firefox18: --- → fixed
status-firefox19: --- → fixed
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.