Determine what broke the Windows PGO builds without --enable-profiling

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox19+ fixed)

Details

(Assignee)

Description

6 years ago
The regression range is here: https://tbpl.mozilla.org/?tree=Profiling&rev=9835584f5fdd

Comment 1

6 years ago
293bdc2afe11:
https://tbpl.mozilla.org/?tree=Try&rev=2c9b350c6c2f

b011b2c888d1:
https://tbpl.mozilla.org/?tree=Try&rev=db5b31752a62

05e44f47d1bf:
https://tbpl.mozilla.org/?tree=Try&rev=982c5c49b42a
Severity: normal → critical
Status: NEW → ASSIGNED
Keywords: regression
OS: Mac OS X → Windows 7

Comment 5

6 years ago
(Bah hit submit too soon)

So going to blame bug 787703.
Assignee: bmo → nobody
Blocks: 787703
Status: ASSIGNED → NEW
(Assignee)

Comment 6

6 years ago
I'll back it out, thanks a lot for your investigation.

Note that we need to track this as it means busted Windows PGO builds when we uplift 19 to Aurora.
Assignee: nobody → general
tracking-firefox19: --- → ?
Component: General → JavaScript Engine
(Assignee)

Comment 7

6 years ago
Hmm, except that patch could not be backed out cleanly.  Jason, would you mind backing it out as soon as possible, please?  We're not getting any PGO testing on Windows on non-profiling builds (which will become Aurora) because of this bug.  Thanks!
Assignee: general → jorendorff
And we were a little late, since he landed it on Aurora (with the bustage you would expect) at 16:18, 90 minutes before comment 4.
Let's discuss in bug 787703.
(Assignee)

Comment 10

6 years ago
Fixed by backout: https://hg.mozilla.org/integration/mozilla-inbound/rev/df94ebb4b929
Assignee: jorendorff → ehsan
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
status-firefox19: --- → fixed
tracking-firefox19: ? → +
You need to log in before you can comment on or make changes to this bug.