Last Comment Bug 806044 - Continous full page invalidation on http://ie.microsoft.com/testdrive/Performance/ParticleAcceleration/Default.html
: Continous full page invalidation on http://ie.microsoft.com/testdrive/Perform...
Status: RESOLVED INVALID
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 20 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://ie.microsoft.com/testdrive/Per...
Depends on:
Blocks: ietestdrive
  Show dependency treegraph
 
Reported: 2012-10-26 21:58 PDT by mayankleoboy1
Modified: 2013-09-19 19:30 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description mayankleoboy1 2012-10-26 21:58:42 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121026030606

Steps to reproduce:

1. enable paint flashing
2.go to http://ie.microsoft.com/testdrive/Performance/ParticleAcceleration/Default.html


Actual results:

full page invalidation and repaint


Expected results:

minimum repaint
Comment 1 Nick Cameron [:nrc] 2012-12-10 17:03:56 PST
confirmed that it is invalidating the whole page. Not sure if it should or not - the whole canvas should invalidate, but apparently that should not show as a paint flash, and any Thebes layer should not be invalidating.
Comment 2 Matt Woodrow (:mattwoodrow) 2012-12-10 17:34:01 PST
This page has two background divs that are size of the full page (backgradient1, backgradient2), and it alternates them between display:block and display:none (such that only only is visible at a time).

This causes us to re-create the frames, and invalidates.

The gradients are also scarily similar (#BEBEBE vs #BFBFBF). I'm not sure what the point of this is, since you definitely can't see the difference. Maybe just to be annoying?

Anyway, this isn't a bug as content is actually changing. I don't see any easy ways to optimize this, and I doubt it's worth the effort.

Note You need to log in before you can comment on or make changes to this bug.