Closed Bug 806133 Opened 8 years ago Closed 8 years ago

Intermittent reftest leak of 604 bytes (1 nsAuthURLParser, 1 nsHashtable, 1 nsNPAPIPluginInstance, 1 nsNPAPIPluginStreamListener, 1 nsPluginStreamListenerPeer) with leaked ogg-video/black140x100.ogv

Categories

(Core :: Audio/Video, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: intermittent-failure, memory-leak)

+++ This bug was initially created as a clone of Bug #766886 +++

Breaking the black140x100.ogv cases out from bug 766886.

Context:

(In reply to Phil Ringnalda (:philor) from bug 766886 comment #354)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=16509695&tree=Mozilla-Inbound
> 
> Looks like we're probably on our own here. Alas, it's not as easy to disable
> our way to victory as the (former) summary would make it seem -
> neverending.sjs is only used by test_pluginstream_seek_close.html, but the
> reftests we've been dropping in here so long that I thought that was what
> the bug was about seem to be leaking something that
> http://mxr.mozilla.org/mozilla-central/search?string=black140x100.ogv says
> is used in 33 reftests. So probably our first step is going to be to file a
> separate Video/Audio bug for them, and then we can use this bug to just
> disable test_pluginstream_seek_close.html since nobody wants to fix it, and
> see whether or not anyone will want to fix those once they are in the right
> lap.

This bug is specifically about the reftest instances at:
http://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=766886&entireHistory=true&tree=trunk
...which have until now been mis-starred as bug 766886.
https://tbpl.mozilla.org/php/getParsedLog.php?id=16528077&tree=Mozilla-Inbound
Summary: Intermittent leak of 1 nsAuthURLParser, 1 nsHashtable, 1 nsNPAPIPluginInstance, 1 nsNPAPIPluginStreamListener, 1 nsPluginStreamListenerPeer with leaked ogg-video/black140x100.ogv → Intermittent reftest leak of 1 nsAuthURLParser, 1 nsHashtable, 1 nsNPAPIPluginInstance, 1 nsNPAPIPluginStreamListener, 1 nsPluginStreamListenerPeer with leaked ogg-video/black140x100.ogv
Summary: Intermittent reftest leak of 1 nsAuthURLParser, 1 nsHashtable, 1 nsNPAPIPluginInstance, 1 nsNPAPIPluginStreamListener, 1 nsPluginStreamListenerPeer with leaked ogg-video/black140x100.ogv → Intermittent reftest leak of 604 bytes (1 nsAuthURLParser, 1 nsHashtable, 1 nsNPAPIPluginInstance, 1 nsNPAPIPluginStreamListener, 1 nsPluginStreamListenerPeer) with leaked ogg-video/black140x100.ogv
roc, please may you look at this.

We're leaking ogg-video/black140x100.ogv, used by 33 reftests (see comment 0), so would have to disable all of them, which I imagine we would both like to avoid.

Thank you :-)
Flags: needinfo?(roc)
Chris D, can you please assign this to someone? Thanks :-)
Assignee: nobody → chris.double
Flags: needinfo?(roc)
Actually, wallpapering it might not require disabling all of the reftests that use black140x100.ogv, and it might be a single Core::Plugins bug after all. In bug 766886 we first disabled test_pluginstream_seek_close.html, which has a <embed src="neverending.sjs"...>, and still leaked, and then we disabled test_streamatclose.html which sets the .src from script, and we stopped leaking.

So while you do have 33 reftests that use black140x100.ogv, it's entirely possible that disabling our way to victory only involves the four of them that set .src from script.
(In reply to Phil Ringnalda (:philor) from comment #53)
> So while you do have 33 reftests that use black140x100.ogv, it's entirely
> possible that disabling our way to victory only involves the four of them
> that set .src from script.

Ah good point :-D
(In reply to David Baron [:dbaron] from comment #108)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=16928409&tree=Mozilla-Aurora
> Rev4 MacOSX Lion 10.7 mozilla-aurora debug test mochitest-other

Er, scratch that, this was bug766886 (neverending.sjs, not black140x100.ogv).  Added comment there.
Alas, https://tbpl.mozilla.org/?tree=Try&rev=25518bf345bb still leaked 3 in 20 times, so it's apparently not just the results of setting the src from script.
Looks like this was fixed by bug 766886 :-)
Assignee: chris.double → nobody
Status: NEW → RESOLVED
Closed: 8 years ago
No longer depends on: 766886
Resolution: --- → DUPLICATE
Duplicate of bug: 766886
But at least it did slow the leak down quite a bit. Or the leak is associated with network troubles in the buildfarm, and they slowed down coincidentally at the same time.

https://tbpl.mozilla.org/php/getParsedLog.php?id=17154727&tree=Mozilla-Inbound
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I found another way to reproduce this in bug 812629 that causes a permanent leak rather than shut-down race, which might be behind some of these.
Depends on: 812629
Whiteboard: [orange]
The other instance of this leak I found in bug 812629 is now fixed, optimistically resolving this again...
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.