JavaScript error in pageInfo.js with broken image

RESOLVED FIXED

Status

SeaMonkey
Page Info
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({testcase})

unspecified
testcase

SeaMonkey Tracking Flags

(seamonkey2.14 fixed, seamonkey2.15 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Steps to reproduce problem:
1. Load attachment 671645 [details]
2. Open Page Info
3. Switch to the Media tab

Actual result:

Error: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [imgIRequest.image]
Source File: chrome://navigator/content/pageinfo/pageInfo.js
Line: 1247
(Assignee)

Comment 1

5 years ago
Created attachment 675904 [details] [diff] [review]
Proposed patch

We only access imageRequest.image to access its numFrames. Sadly numFrames was removed over a year ago so the whole block is now useless. On trunk we can investigate porting bug 713889, but for the sake of the branches I have split the work into two halves, which is why this patch is just the minimal changes and does not do any potential code cleanup. To help simplify the second half of the work, I have also swapped the order of the mime type detection. The !isBG check is a random fix that I happened to notice at the same time.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #675904 - Flags: review?(iann_bugzilla)

Comment 2

5 years ago
q.v. Bug 792735 Comment 13.
Blocks: 792735

Comment 3

5 years ago
Comment on attachment 675904 [details] [diff] [review]
Proposed patch

>   var numFrames = 0;
I presume this is still needed for the second half of the work?
Attachment #675904 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 4

5 years ago
I didn't want to change code that the other patch will end up changing anyway.
(Assignee)

Comment 5

5 years ago
Pushed comm-central changeset 2204125b352d.
(Assignee)

Comment 6

5 years ago
Comment on attachment 675904 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 491310
User impact if declined: JavaScript error in some cases
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None
Attachment #675904 - Flags: approval-comm-beta?
Attachment #675904 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #675904 - Flags: approval-comm-beta?
Attachment #675904 - Flags: approval-comm-beta+
Attachment #675904 - Flags: approval-comm-aurora?
Attachment #675904 - Flags: approval-comm-aurora+
(Assignee)

Comment 7

5 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/ae6eff92c445
http://hg.mozilla.org/releases/comm-beta/rev/4666574fa596
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-seamonkey2.14: --- → fixed
status-seamonkey2.15: --- → fixed
You need to log in before you can comment on or make changes to this bug.