Closed Bug 806205 Opened 7 years ago Closed 7 years ago

browser_bug435325.js test fails

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(seamonkey2.15 fixed, seamonkey2.16 fixed)

RESOLVED FIXED
seamonkey2.16
Tracking Status
seamonkey2.15 --- fixed
seamonkey2.16 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

References

Details

Attachments

(1 file)

This browser chrome test http://mxr.mozilla.org/comm-central/source/suite/browser/test/browser/browser_bug435325.js currently fails because of the changes in Bug 87717 (the test proxy on localhost is now always reachable, even in offline mode). The Firefox test already has a fix, we just need to copy it.
Attached patch PatchSplinter Review
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #675950 - Flags: review?(iann_bugzilla)
Depends on: 87717
Comment on attachment 675950 [details] [diff] [review]
Patch

Patch has been tested locally via executing the command "TEST_PATH=suite/browser/test/ make mochitest-browser-chrome" in the objdir.
This patch fixes the main test error, but there's still a second test error:
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/br
owser_bug435325.js | Cleanup function threw an exception - [Exception... "Compon
ent returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.getEntryAt
Index]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrom
e://navigator/content/tabbrowser.xml :: removeTab :: line 1728"  data: no]

I suggest we look at this in another bug or patch. This test failure is very likely not caused by my patch.
Comment on attachment 675950 [details] [diff] [review]
Patch

>+let proxyPrefValue;
I would prefer var rather than let here.

r=me
Attachment #675950 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 675950 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: -
Testing completed (on m-c, etc.): This is a test itself and the test currently fails
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: -

Not sure if I actually need approval for test fixes like this. Anyway, this test currently fails as the fix for Bug 87717 has already been moved to mozilla-aurora as part of the rapid release process:
NEXT ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/browser_bug435325.js | Loading the Offline mode neterror page. - Got http://example.com/, expected about:neterror?e=netOffline
Attachment #675950 - Flags: approval-comm-aurora?
Pushed to comm-central: https://hg.mozilla.org/comm-central/rev/892a9063f5aa
Target Milestone: --- → seamonkey2.16
Comment on attachment 675950 [details] [diff] [review]
Patch

a=me provided that the test fails on Aurora without and succeeds with the patch (didn't check).
Attachment #675950 - Flags: approval-comm-aurora? → approval-comm-aurora+
Pushed to comm-aurora: http://hg.mozilla.org/releases/comm-aurora/rev/34d83739a9e9
I verified that the test buildboxen no longer fail. It looks like the nsISHistory exception occurred only locally on my PC.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.