Closed Bug 806239 Opened 7 years ago Closed 7 years ago

Sending the dump-memory-reports-after-minimize signal results in two sets of reports

Categories

(Toolkit :: about:memory, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed

People

(Reporter: justin.lebar+bug, Assigned: justin.lebar+bug)

References

Details

Attachments

(1 file)

I'm missing a return statement.
Attached patch Patch, v1Splinter Review
Attachment #675986 - Flags: review?(n.nethercote)
Comment on attachment 675986 [details] [diff] [review]
Patch, v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 800486

I know this isn't yet r+'ed, but I'm requesting approval anyway because this is a zero risk, brain-dead bug that I would like to get to B2G users as soon as possible, because it's keeping us from correctly getting memory reports off the device.
Attachment #675986 - Flags: approval-mozilla-aurora?
Blocks: 800486
Assignee: nobody → justin.lebar+bug
Attachment #675986 - Flags: review?(n.nethercote) → review+
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): Bug 800486
> 
> I know this isn't yet r+'ed, but I'm requesting approval anyway because this
> is a zero risk, brain-dead bug that I would like to get to B2G users as soon
> as possible, because it's keeping us from correctly getting memory reports
> off the device.

I concur!  This should be on Aurora ASAP.
https://hg.mozilla.org/mozilla-central/rev/9e606320e6a5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Willing to approve this as soon as we have the risk assessment for desktop/mobile or a confirmation that the m-c bake time is good enough to notice any obvious regressions.Thanks !
I indicated in comment 2 that this is a zero-risk bug.
(In reply to Justin Lebar [:jlebar] from comment #7)
> I indicated in comment 2 that this is a zero-risk bug.

Or, a zero risk bug-fix, in any case.
To elaborate: This code is not run unless you send a special signal from the operating system to Firefox.  We do this on B2G, and you can do it on Linux desktop too, if you want.  But nobody is doing it accidentally.  So this is a zero-risk fix to debugging-only code.
Attachment #675986 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Justin Lebar [:jlebar] from comment #9)
> To elaborate: This code is not run unless you send a special signal from the
> operating system to Firefox.  We do this on B2G, and you can do it on Linux
> desktop too, if you want.  But nobody is doing it accidentally.  So this is
> a zero-risk fix to debugging-only code.

Thanks for your quick response ! Patch is approved for aurora considering your comments
You need to log in before you can comment on or make changes to this bug.