Last Comment Bug 806283 - Include native iterators in "object/misc" memory reports.
: Include native iterators in "object/misc" memory reports.
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla19
Assigned To: Nicholas Nethercote [:njn]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: B2GDarkMatter
  Show dependency treegraph
 
Reported: 2012-10-28 22:51 PDT by Nicholas Nethercote [:njn]
Modified: 2012-11-07 19:25 PST (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Include native iterators in "object/misc" memory reports. (4.41 KB, patch)
2012-10-28 22:52 PDT, Nicholas Nethercote [:njn]
no flags Details | Diff | Splinter Review
Split up and add native iterators to "object/misc" memory reports. (15.42 KB, patch)
2012-10-29 17:14 PDT, Nicholas Nethercote [:njn]
jorendorff: review+
bajaj.bhavana: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2012-10-28 22:51:59 PDT
We don't measure NativeIterator objects pointed to by the private slot of
PropertyIteratorObjects.
Comment 1 Nicholas Nethercote [:njn] 2012-10-28 22:52:22 PDT
Created attachment 676048 [details] [diff] [review]
Include native iterators in "object/misc" memory reports.

This patch typically measures a few 100 KBs of NativeIterator objects, esp. in
B2G profiles.
Comment 2 Justin Lebar (not reading bugmail) 2012-10-29 07:46:53 PDT
Do we want to split these out, so we have more visibility into where our memory is going?
Comment 3 Nicholas Nethercote [:njn] 2012-10-29 17:14:39 PDT
Created attachment 676402 [details] [diff] [review]
Split up and add native iterators to "object/misc" memory reports.

This revised patch: 

- Splits up the "objects/misc" entry into three parts: "arguments-data",
  "regexp-statics", and "property-iterator-data".  
  
- Renames the "objects" sub-path as "objects-extra", to match "shapes-extra"
  (and better distinguish it from the "gc-heap/objects/*" reports).
Comment 4 Nicholas Nethercote [:njn] 2012-11-01 20:35:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2f8306353ae9
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-11-02 17:26:31 PDT
https://hg.mozilla.org/mozilla-central/rev/2f8306353ae9
Comment 6 Nicholas Nethercote [:njn] 2012-11-02 19:48:40 PDT
Comment on attachment 676402 [details] [diff] [review]
Split up and add native iterators to "object/misc" memory reports.

[Approval Request Comment]

Bug caused by (feature/regressing bug #):  N/A

User impact if declined: less insight into memory consumption for B2G.

Testing completed (on m-c, etc.): landed on m-c today.

Risk to taking this patch (and alternatives if risky): negligible;  code only runs when about:memory is loaded or a memory report is triggered. 

String or UUID changes made by this patch: none.
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-11-07 18:54:47 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/c0dfb00e3030

This required a bit of unbitrotting to apply to Aurora, but it was pretty mechanical. Probably wouldn't hurt to look it over as a sanity check, though.
Comment 8 Nicholas Nethercote [:njn] 2012-11-07 19:25:54 PST
Probably wouldn't hurt to look it over as a sanity check, though.

> Looks ok to me.  Thanks for uplifting it.

Note You need to log in before you can comment on or make changes to this bug.