Closed Bug 806310 Opened 8 years ago Closed 8 years ago

"ASSERTION: canStoreInRuleTree must be false for inherited structs unless all properties have been specified with values other than inherit"

Categories

(Core :: CSS Parsing and Computation, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(3 files)

Attached file testcase
###!!! ASSERTION: canStoreInRuleTree must be false for inherited structs unless all properties have been specified with values other than inherit: '!canStoreInRuleTree || aRuleDetail == eRuleFullReset || (aStartStruct && aRuleDetail == eRulePartialReset)', file layout/style/nsRuleNode.cpp, line 3555
Attached file stack
Hmm.  Looks like a regression from bug 804970.

In particular, CheckFontCallback changes full/partial reset RuleDetail values to the corresponding full/partial mixed values if IsRelativeLengthUnit(), which I assume is being hit here.  But we can in fact store those in the ruletree now, for rem.  So we should probably just check for em, not rem, in CheckFontCallback....  David?
Blocks: 804970
Comment on attachment 680276 [details] [diff] [review]
Fix CheckFontCallback to match 'rem' unit changes.  ()

r=me
Attachment #680276 - Flags: review?(bzbarsky) → review+
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/60df5b3e7137
https://hg.mozilla.org/mozilla-central/rev/98e22583895a
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.