Port PATH buildbot config change to fix Lion OS X builds

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Currently the new Mac OS X 10.7 comm-central builds fail with this error:

New python executable in /builds/slave/comm-cen-trunk-osx64-ntly/build/objdir/i386/mozilla/_virtualenv/bin/python2.7
Also creating executable in /builds/slave/comm-cen-trunk-osx64-ntly/build/objdir/i386/mozilla/_virtualenv/bin/python
Overwriting /builds/slave/comm-cen-trunk-osx64-ntly/build/objdir/i386/mozilla/_virtualenv/lib/python2.7/distutils/__init__.py with new content
Traceback (most recent call last):
  File "/builds/slave/comm-cen-trunk-osx64-ntly/build/mozilla/python/virtualenv/virtualenv.py", line 2471, in <module>
    main()
  File "/builds/slave/comm-cen-trunk-osx64-ntly/build/mozilla/python/virtualenv/virtualenv.py", line 942, in main
    never_download=options.never_download)
  File "/builds/slave/comm-cen-trunk-osx64-ntly/build/mozilla/python/virtualenv/virtualenv.py", line 1045, in create_environment
    install_distutils(home_dir)
  File "/builds/slave/comm-cen-trunk-osx64-ntly/build/mozilla/python/virtualenv/virtualenv.py", line 1526, in install_distutils
    writefile(os.path.join(distutils_path, '__init__.py'), DISTUTILS_INIT)
  File "/builds/slave/comm-cen-trunk-osx64-ntly/build/mozilla/python/virtualenv/virtualenv.py", line 454, in writefile
    f = open(dest, 'wb')
IOError: [Errno 13] Permission denied: '/builds/slave/comm-cen-trunk-osx64-ntly/build/objdir/i386/mozilla/_virtualenv/lib/python2.7/distutils/__init__.py'

The problem is (probably) the PATH env var:
PATH=/tools/buildbot/bin:/tools/python/bin:/opt/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin

/tools/buildbot/bin already contains a Python virtual env which breaks the build (creating a new virtualenv from a virtualenv does not seem to work).

The solution is to port/apply the same buildbot config fix as in Bug 758694 which will move /tools/python/bin before /tools/buildbot/bin in PATH.
(Assignee)

Comment 1

6 years ago
Created attachment 676095 [details] [diff] [review]
Patch

This patch fixes the PATH var for OS X. For now I have only changed the OS X 10.6 (10.7 actually) PATH var as I did not want to mess around with the OS X 10.5 builds before making sure that it has the same issue.
Assignee: nobody → bugzilla
Attachment #676095 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 2

6 years ago
Comment on attachment 676095 [details] [diff] [review]
Patch

Pushed to seamonkey-production branch: http://hg.mozilla.org/build/buildbot-configs/rev/0024a02277d9
Attachment #676095 - Flags: review?(bugspam.Callek) → review+
This went live, and did indeed help fix us.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.