pressingn backspace twice causes entire text to be deleted

RESOLVED DUPLICATE of bug 792928

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 792928
5 years ago
a year ago

People

(Reporter: 133794m3r, Unassigned)

Tracking

16 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I type something into a form, make a misspelling/typo. Press the backspace twice rather quickly(to delete two characters)


Actual results:

It deletes either a) everything or b) everything but the last word.


Expected results:

It should've deleted just the last two characters. It is in there since firefox switched to the "native java ui" before that it worked just fine. The keyboard does this in _only_ firefox for android, no other application on android does this. It is only firefox adn it is really annoying. I am isnanely close to just switching to chrome since it doesn't pull these kinds of stunts on me randomly. This issue is still present in the latest release.
(Reporter)

Comment 1

5 years ago
I am running it on GNex VZW, 4.1 ICS stock. The same issue happens on my grandparent's droid x2, and also has happened on my mother's thunderbolt. Running ICS 4.0, and gingerbread. This issue was there before 4.1 and also after it, also it's been there a long time, it's been there forever. Completely uninstalling firefox/reinstalling it doesn't fix the issue. It is still there.

I don't know when it got in there exactly but I've noticed it since firefox switched to the native ui/14(if I remember right), and has gotten progressively worse with every release. It's not 100% of the time, it's more ~85%+ of the time that it does this. I don't know if you guys are trying to be "smart" but stop, it breaks usability, and I am about to abandon firefox because I've lost way too many messages due to this issue.
This is fixed on trunk, and will be uplifted to mozilla-aurora in the next few days.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 792928
You need to log in before you can comment on or make changes to this bug.