Panning is not working on certain zoom levels if pinch to reflow text is enabled

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: xti, Unassigned)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Firefox 19.0a1 (2012-10-29)
Device: Galaxy R
OS: Android 2.3.4

Steps to reproduce:
1. Go to Menu > Settings and enable Pinch to Reflow Text option
2. Go to cnn.com and tap on any news
* from this point, always keep on finger on the screen
3. Pinch-to-zoom in the page
4. Pan the page around
5. Pinch-to-zoom out the page
6. Verify if the pan it's working properly

Expected result:
Panning is working fine on any zoom level

Actual result:
Panning is working only when the zoom level is or is close to the default level.

Note: http://youtu.be/4t3fVo3JM6w
This only happens if pinch-to-reflow is turned on, right?
Blocks: 710298
Keywords: regression
(Reporter)

Comment 2

5 years ago
(In reply to Kartikaya Gupta (:kats) from comment #1)
> This only happens if pinch-to-reflow is turned on, right?

That's right. I cannot reproduce it if this option is disabled
Pinch to reflow is gone now, so closing WFM.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 4

4 years ago
I've just tested this and the same happens but why would you use a Web browser that way in the first place?


Take your finger off and panning works again. I've never used a touchscreen browser in the way the op describes to start with.


The only other way to zoom is to double tap and by definition you've lifted your finger off the screen. So by disabling pinch to zoom you're not going to come across this problem.

Is this really a bug or by design?

Comment 5

4 years ago
I'm using Firefox 23 btw.
You need to log in before you can comment on or make changes to this bug.