Closed Bug 806624 Opened 10 years ago Closed 10 years ago

(dev mode only) Support using hosted apps with certified permissions

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set
normal

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

RESOLVED FIXED
mozilla19
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: jlal, Assigned: fabrice)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-needed, Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

The use case for me is Gaia Calendar since we have removed support for building the permissions directly from gaia.
The other fallout from this is its very difficult to play with cool new things like systemXHR without using b2g-desktop.
Marking blocking? this indirectly effects anyone who was using Firefox Nightly as a development environment (as I have been for 3+ months). I am aware of several others on the gaia side 3rd party devs aside.
blocking-kilimanjaro: --- → ?
Did you mean to nom the basecamp flag?
heh thanks jsmith
blocking-basecamp: --- → ?
blocking-kilimanjaro: ? → ---
I would very much like to see this working, for both Gaia developers and to allow third party developers to develop web apps inside Firefox, with all the developer tools.

Without this, I think the only way to develop an app which uses any privileged APIs in Firefox is to re-package and re-install a packaged app every time you make a change! This is not a very good developer experience.
Assignee: nobody → fabrice
blocking-basecamp: ? → +
Attached patch patch (obsolete) — Splinter Review
Attached patch patch v2Splinter Review
Attachment #676680 - Attachment is obsolete: true
Comment on attachment 676746 [details] [diff] [review]
patch v2

James confirmed that he could use the calendar app of fx desktop with this patch.
Attachment #676746 - Flags: review?(21)
by wrapping it in a mozapp iframe after installing the app I got my systemXHR perms back. There may be issues with other permissions, I attempted the same technique with browser but still could not open google/yahoo (which use x-frames disallow and other techniques to prevent framing).

I will have an example incorporated into my next gaia patch if other apps want to take/improve whatever I come up with.
https://hg.mozilla.org/mozilla-central/rev/4db087039e17
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Keywords: verifyme
QA Contact: jsmith
I'm looking at this for doc purposes. Was this implemented only as a convenience for developers so they do not have to zip and install a certified app to test a code change?
This preference is a convenience for developers so that they can pretend their app has a "certified" status and thus can use APIs that are only available for certified apps. I implemented that initially only for packaged apps, but developers need that also for hosted apps since that suits their workflow better.
Keywords: verifyme
Whiteboard: [qa-]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.