Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: billm, Assigned: billm)

Tracking

unspecified
mozilla19
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17 fixed, firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 676409 [details] [diff] [review]
backout patch

This is causing a regression in bug 806087. It also may be related to bug 782072.
Attachment #676409 - Flags: review?(terrence)
Attachment #676409 - Flags: review?(terrence) → review+
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/cb997ba8433b
(Assignee)

Comment 2

5 years ago
Comment on attachment 676409 [details] [diff] [review]
backout patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 778993
User impact if declined: OOM during syncs of big profiles.
Testing completed (on m-c, etc.): On m-c.
Risk to taking this patch (and alternatives if risky): Low. It's purely a heuristic change and it reverts to FF16 behavior.
String or UUID changes made by this patch: None.
Attachment #676409 - Flags: approval-mozilla-beta?
Attachment #676409 - Flags: approval-mozilla-aurora?
Comment on attachment 676409 [details] [diff] [review]
backout patch

yes to this backout, pre-approving for aurora/beta even though this is only on inbound right now so that there's time to get this landed as early as it can be (ie: before tomorrow at noon PT) and we get this backout in our 17 Beta 4 builds.
Attachment #676409 - Flags: approval-mozilla-beta?
Attachment #676409 - Flags: approval-mozilla-beta+
Attachment #676409 - Flags: approval-mozilla-aurora?
Attachment #676409 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/8ff69d6c9151
https://hg.mozilla.org/releases/mozilla-beta/rev/2a61e12f904b

Updated

5 years ago
status-firefox17: --- → fixed
status-firefox18: --- → fixed
https://hg.mozilla.org/mozilla-central/rev/cb997ba8433b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
status-firefox19: --- → fixed
You need to log in before you can comment on or make changes to this bug.