Social API breaks viewing Flash videos

RESOLVED DUPLICATE of bug 805331

Status

()

RESOLVED DUPLICATE of bug 805331
6 years ago
6 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I've been seeing this for a while but haven't gotten around to filing a bug. :(

Seems many flash videos are no longer working for me on Nightly + Retina + Flash 11.4.402.287. Not sure if this is a Flash issue or Firefox, or when exactly it changed. :/

All I get is a black rectangle. Sometimes, if the video is set to autoplay, I may see a few initial frames (or a static image?), and then it's replaced with a black box. Often I'll continue to hear audio, but can't interact with the controls.

I suspect this might involve Retina because a right-click on a broken video will display the Flash context menu significantly offset from where I clicked.

Example:

http://vimeo.com/35193017
(Reporter)

Comment 1

6 years ago
Hmm, I can easily reproduce this in my regular Nightly profile, but it seems ok in a new profile. Let me investigate.
(Reporter)

Comment 2

6 years ago
Ok, I can easily reproduce in a "new" profile via:

  mkdir /tmp/foo
  cd $oldprofile
  cp * /tmp/foo

Tried fiddling a few knobs, and then got Flash working when I disabled social.enabled. To be sure, I recreated my test profile with the above (still broken), disabled just social.enabled, and Flash started working again.

Are we doing something funny with the Social API sandboxes that could cause Flash to get into some wedged state?

I'm not sure how to further debug this. :/
Summary: Flash problem with Retina? → Social API breaks viewing Flash videos
(Reporter)

Comment 3

6 years ago
Also reproducible when not logged into Facebook, so hopefully that makes it easier to reproduce for someone.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805331
You need to log in before you can comment on or make changes to this bug.