Closed Bug 806728 Opened 7 years ago Closed 7 years ago

Port test_bug468700.js to the new per-tab PB APIs

Categories

(Firefox :: Private Browsing, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 826311

People

(Reporter: ehsan, Unassigned)

References

(Blocks 1 open bug)

Details

http://mxr.mozilla.org/mozilla-central/source/extensions/cookie/test/unit/test_bug468700.js

In order to port this test, the file needs to be copied to the same directory (perhaps with "_perwindowpb" appended to its file name), and then instead of setting privateBrowsingEnabled, we need to open a new private browsing window and then run the test on that window.  Note that the original test should only be added to the list of test files in Makefile.in ifndef MOZ_PER_WINDOW_PRIVATE_BROWSING, and the new test file should be added to the list with the reverse condition.

(Josh, does this already have a per-window PB equivalent?)
This test has some problems that prevent a straightforward conversion:
* there is nothing window-related about it
* it's using various methods such as nsCookieService::CountCookiesFromHost which (when bug 722850 lands) only looks at the public cookie database.
Hmm, good point.  So, bug 722850 will make the cookie permission code not use the global PB service.  This test is meant to test bug 468700 which added that code.  Perhaps this test can be rewritten to actually test the behavior described in bug 468700 comment 0.
Depends on: 722850
Removed this test from per-window PB builds: https://hg.mozilla.org/mozilla-central/rev/33a1ad2d4f03
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826311
You need to log in before you can comment on or make changes to this bug.