All users were logged out of Bugzilla on October 13th, 2018

Cookie text appearing above banners of bug lists in all non Mozilla browsers

VERIFIED FIXED in Bugzilla old

Status

()

P1
trivial
VERIFIED FIXED
20 years ago
6 years ago

People

(Reporter: Crysgem, Assigned: bryce-mozilla)

Tracking

unspecified
Bugzilla old
x86
Windows 98

Details

(Reporter)

Description

20 years ago
Sing, children! "Inter-op-'rability..."

Eminently reproducible with any bug query, including those that return no bugs.
Example extraneous output:

Content-type: text/html Set-Cookie: BUGLIST=3589:1182:2669 ...

Comment 1

20 years ago
I think this will be fixed by a checkin that Bryce is about to make.  I'm
reassigning to him to confirm this fact, and to close when he checks in his
change.
Assignee: terry → bryce-mozilla
Summary: Cookie text appearing above banners of bug lists in MSIE 5.0 → Cookie text appearing above banners of bug lists in MSIE 5.0
(Assignee)

Updated

20 years ago
Assignee: bryce-mozilla → terry
Priority: P3 → P1
(Assignee)

Comment 2

20 years ago
No, I only changed the browser type test (before it assumed that Mozilla and
MSIE were the only options).

The non-mozilla non-serverpush case is still badly broken, but I did not feel
comfortable enough that I understood the situation to fix it.  The code is a bit
convoluted especially because the saved query stuff is setting all sorts of
cookies, and there are lots of different paths that might produce output.

In any case, the result is an extra "Content-type:" gets printed, and the cookie
gets treated as HTML.  To reproduce the bug with Mozilla, just force $serverpush
to zero.
(Assignee)

Updated

20 years ago
Summary: Cookie text appearing above banners of bug lists in MSIE 5.0 → Cookie text appearing above banners of bug lists in all non Mozilla browsers
(Assignee)

Comment 3

20 years ago
The bug will affect ALL brosers other than Mozilla 3.0+.  The cookie won't
function either.
(Assignee)

Updated

20 years ago
Assignee: terry → bryce-mozilla
(Assignee)

Comment 4

20 years ago
Ok, ok, I'll grab it.  It's the only really serious functional bug in the
database...
(Reporter)

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 5

20 years ago
Should the status not be marked as Assigned, then?
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

20 years ago
It was assigned.  Now it is fixed.  Submitting this
with Opera just to make sure :-).
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 7

20 years ago
Hail to your algorithms! Marking: Verified--Fixed.
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.