All users were logged out of Bugzilla on October 13th, 2018

When a bezier SVG curve is moved it does not render correctly for jsPlumb

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ufokaradagli, Unassigned)

Tracking

({regression})

16 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17- wontfix, firefox18 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 676654 [details]
jsPlumb-Firefox-Bug.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121023124120

Steps to reproduce:

http://jsplumb.org/jquery/draggableConnectorsDemo.html

(as of Firefox 15)
tried to make jsPlumb connections


Actual results:

SVG path is not rendered correctly while moving the connection and after connection is made. After my tests I think it happens only when the connection is moved towards +x,+y.


Expected results:

SVG paths should have been rendered correctly

Here is the closed issue in jsPumb:
http://code.google.com/p/jsplumb/issues/detail?id=283

Comment 1

6 years ago
I can reproduce in Firefox16.0.2 and Firefox17.0beta but not in Aurora18.0a2 and later.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/cb2904476d14
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120623195143
First Bad:
http://hg.mozilla.org/mozilla-central/rev/c659521a7a9a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120624200544
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb2904476d14&tochange=c659521a7a9a

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/248f55ae4b23
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120623235543
First Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5c26b1320e1a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120624060243
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=248f55ae4b23&tochange=5c26b1320e1a

Suspected: Bug 738192


Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/b274e8e3479f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928160219
Fixed:
http://hg.mozilla.org/mozilla-central/rev/b62b229a4d41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928161018
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b274e8e3479f&tochange=b62b229a4d41

Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9f476b4ac1e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928040137
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b58397ad735
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928042236
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735

This seems to be fixed by Bug 539356
Blocks: 738192
Status: UNCONFIRMED → NEW
tracking-firefox17: --- → ?
Component: Untriaged → SVG
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Version: 17 Branch → 16 Branch
Since we already shipped this regression with 15 and 16, and the fix in bug 539356 is way too much to uplift at this stage in 17's beta cycle, I'm minusing for tracking.  We will have to live with this regression for 6 more weeks until 18 ships with the fix.
status-firefox17: --- → wontfix
tracking-firefox17: ? → -
Closing as fixed by bug 539356.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox18: --- → fixed
Depends on: 539356
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.