Nightly Button repaints the whole tab bar

RESOLVED DUPLICATE of bug 786485

Status

()

RESOLVED DUPLICATE of bug 786485
6 years ago
6 years ago

People

(Reporter: mayankleoboy1, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 676927 [details]
about support.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121030030633

Steps to reproduce:

1. Enable debug paint flashing
2. Open a new tab.
3. Put mouse on the nightly button in the top left corner.


Actual results:

The entire tab bar repaints.


Expected results:

Minimal repaint.
(Reporter)

Comment 1

6 years ago
If you open ~25 tabs (even newTabs) then you can observe large janks in the profiler.
(Reporter)

Updated

6 years ago
Summary: Mouse hover on the Nightly Button causes whole tab bar to repaint → Nightly Button repaints the whole tab bar
Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/19.0 Firefox/19.0
Buid ID: 20121105030642

I can confirm that the tab bar repaints entirely.
Component: Untriaged → Layout
Product: Firefox → Core
(Reporter)

Comment 3

6 years ago
can also reproduce this on FF15. So its probably an old bug.
Duplicate of this bug: 809334

Comment 5

6 years ago
WFM with 2012-11-01-03-07-05-mozilla-central-firefox-19.0a1.en-US.linux-x86_64
Blocks: 539356

Updated

6 years ago
No longer blocks: 539356
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786485
You need to log in before you can comment on or make changes to this bug.