Closed Bug 807264 Opened 7 years ago Closed 6 years ago

IPC parent aborts with malformed PContent::Msg_StartVisitedQuery

Categories

(Core :: IPC, defect, critical)

ARM
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 780219

People

(Reporter: posidron, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Attachments

(1 file)

Attached file callstack
[PContentChild] Sending Msg_StartVisitedQuery([TODO])
==> type unsigned long long original value: 1 / now: 18446744073709551615

An interception occurred only then if XRE_GetProcessType() equaled GeckoProcessType_Content.

Let me know if you need further information.
Is there a test case for this?
DCHECK() abort in Pickle::ReadSize(). Duplicate of 780219.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780219
You need to log in before you can comment on or make changes to this bug.