Closed Bug 807599 Opened 9 years ago Closed 9 years ago

Can't copy and paste from Google Translate since Firefox 16.0.2

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: seb, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

When using Google translate
http://translate.google.com
Type anything in the left.
Translation appears on the right.
Try to copy the translation to the clipboard.


Actual results:

Translation will not copy to clipboard.  Neither Ctrl-C or context menu Copy will copy the text.  Copy is shown and available in the context menu, but doesn't do anything.
First noticed this after Firefox 16.0.2 update.


Expected results:

Text should become available in the clipboard.
I can also reproduce and we have users which face same problem:
https://bugzilla.redhat.com/show_bug.cgi?id=872014
Same problem with Fedora/Linux.
Component: Untriaged → XUL
OS: Windows XP → All
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Component: XUL → Event Handling
Ever confirmed: true
I can reproduce this with Firefox 6 as well on Ubuntu, so this is not a recent regression.

Maybe a recent Google update for the translator?
I'm not sure if it worked a day, because I tried with 4.0 nightlies and the issue was already present.
It works fine in IE9.
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/ebfe0dc025da
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100319 Minefield/3.7a4pre ID:20100319070050
Bad:
http://hg.mozilla.org/mozilla-central/rev/27259a0fcbe6
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100319 Minefield/3.7a4pre ID:20100319121352
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ebfe0dc025da&tochange=27259a0fcbe6

Triggered by: Bug 501154
Blocks: 501154
Version: 16 Branch → 2.0 Branch
Keywords: regression
But something must have changed recently in Google Translate if it used to work
with FF15.
Duplicate of this bug: 807621
Setting dom.event.clipboardevents.enabled = false helps
Component: Event Handling → DOM: Events
"Setting dom.event.clipboardevents.enabled = false helps"

This change, or we enter where and how?

V.
Assignee: nobody → english-us
Component: DOM: Events → English US
Product: Core → Tech Evangelism
Version: 2.0 Branch → unspecified
(In reply to vilem from comment #9)
> "Setting dom.event.clipboardevents.enabled = false helps"
> 
> This change, or we enter where and how?
> 
> V.

Type about:config in the location bar and search for dom.event.clipboardevents.enabled.
The page is modifying the selection during the cut/copy events, causing nothing to be in the selection to copy.
"Ctrl + C" works, if you hold it for 1 or 2 seconds.
(In reply to Iceberg from comment #12)
> "Ctrl + C" works, if you hold it for 1 or 2 seconds.

I confirm this behavior.
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0(.2)
(In reply to Iceberg from comment #12)
> "Ctrl + C" works, if you hold it for 1 or 2 seconds.

Yep. We perform the shortcut on keypress, which repeats, so one of the repeats is likely working. The page is probably not changing the selection or performing some subtly different code in that case.

This issue doesn't occur on most other browsers, because they receive a more ordinary version of the page, whereas Firefox receives an 'enhanced' version that translates automatically as you type.
(In reply to Neil Deakin from comment #14)
> This issue doesn't occur on most other browsers, because they receive a more
> ordinary version of the page, whereas Firefox receives an 'enhanced' version
> that translates automatically as you type.

Yes, but if IE 8 (for example) works because it receives a more ordinary version of the page, Opera 12.02 (for example) works and it receives the same version 'enhanced' of Firefox.
Good morning

I hope we can resolve this bug as soon as possible, the copy-paste with Google translated for me it is essential to communicate with the rest of the world


THANKS
I am on ff 13 beta.

And the problem started occurring in that also for last a week or so.

So, it is not just 16.02 that has that problem. it is on previous versions also.

see the thread in firefox support ng.

-- 
Rawat
(In reply to V S Rawat from comment #17)
> I am on ff 13 beta.
> 
> And the problem started occurring in that also for last a week or so.
> 
> So, it is not just 16.02 that has that problem. it is on previous versions
> also.
> 
> see the thread in firefox support ng.
> 
> -- 
> Rawat

I have a clipboard manager (clipdiary) installed. When I saw what has come in clipdiary entry for this copy from google translate, there was this comment there 
"Unknown data format: Data was taken from firefox - Google Translate - 
..."

clicking on other data in clipdiary was pasting that entry to current window, but this error entry was not getting pasted.

Hope this "unknown data format" gives some clue to developers.

Thanks.
-- 
Rawat
Google changed something in the Google Translate, so they need to revert that change.
I've contacted them and hopefully they are looking at the issue ASAP.
Duplicate of this bug: 808385
Looks like Google has fixed this problem.
Indeed. Works here in Finland.
Could we get still some confirmation, say from US to make sure the fix is activated everywhere.
Then we can close this bug.
Yes, it looks like the fault is removed.
V.
Works for me too. I'm using Aurora 20121106042013
Yep, working now for me.  Firefox 16.0.2
Works for me on Firefox 16.0.2.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard

I'd like to re-open this. It looks like Google have 'broken' it again.

I'm finding the exact same issue now with Firefox 76.0.1 (64-bit) on Windows 10. You can select text in the translation result (right-hand panel), right-click and select 'Copy' (or press Ctrl+C), but the clipboard is not updated. Whereas if you select text from the translation input (left-hand panel) and copy, the clipboard is updated as expected.

It clearly needs a fix within Firefox, because no website should be able to prevent copy-and-paste like this.

(There is an icon for 'copy' which works, but that is beside the point.)

I don't seem to be able to re-open this bug, so I will try cloning...

You need to log in before you can comment on or make changes to this bug.