Closed Bug 807623 Opened 8 years ago Closed 8 years ago

panel displayed by tos;dr extension is blank since bug 803068 landed

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla19
Tracking Status
firefox18 --- unaffected
firefox19 + verified

People

(Reporter: jfkthame, Assigned: bholley)

References

Details

(Keywords: addon-compat, regression)

Attachments

(1 file)

Since bug 803068 landed, the panel presented by the tos;dr add-on[1] is showing up completely blank in Nightly builds.

In Nightly builds from mozilla-central:
works: http://hg.mozilla.org/mozilla-central/rev/e069342dc665
fails: http://hg.mozilla.org/mozilla-central/rev/e19e170d2f6d

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e069342dc665&tochange=e19e170d2f6d

Bisecting with local builds points specifically to http://hg.mozilla.org/mozilla-central/rev/779d380a77f8 (bug 803068 part 3) as the changeset where this begins to fail.

I don't have a minimized testcase at this point; STR are to install the tos;dr extension[1], then visit github.com and click on the green (B) icon displayed in the URL bar. Prior to bug 803068, this displays a panel with a summary of terms; now, it displays a blank panel.

[1] https://addons.mozilla.org/en-US/firefox/addon/terms-of-service-didnt-read/
Potential compat regression. Flagging for tracking.
When loading the github.com page with a Nightly since bug 803068 landed (and with the tos;dr addon installed), I see an error message culminating in:

6/11/12 18:19:23.044 [0x0-0x2a29a27].org.mozilla.nightly: TypeError: Object.prototype.toString called on incompatible object

recorded in the console. (This is preceded by a long backtrace with many lines of minified js code, but it's not obvious to me what object is throwing the error.)

This error was not generated using older builds, where the addon works as designed.
Assignee: general → bobbyholley+bmo
Keywords: addon-compat
Looks like these got lost in the Direct Proxy Handler refactor. This appears to
fix tos;dr.
Attachment #679752 - Flags: review?(ejpbruel)
Comment on attachment 679752 [details] [diff] [review]
Reimplement obj_toString and fun_toString traps on BaseProxyHandler. v1

Review of attachment 679752 [details] [diff] [review]:
-----------------------------------------------------------------

Discussed this over irc, patch looks good. Only comment would be that the assertion is already done by Proxy::obj_toString and Proxy::fun_toString (via GetProxyHandler), and these are the only callers to my knowledge. r+
Attachment #679752 - Flags: review?(ejpbruel) → review+
https://hg.mozilla.org/mozilla-central/rev/b5983eb572cb
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0

I can verify this issue on Firefox 19.0 RC (buildID: 20130215130331)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.