Last Comment Bug 807636 - jquery.transit does not work
: jquery.transit does not work
Status: RESOLVED FIXED
: regression
Product: Tech Evangelism
Classification: Other
Component: Desktop (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://ricostacruz.com/jquery.transit/
Depends on:
Blocks: 745523
  Show dependency treegraph
 
Reported: 2012-11-01 06:30 PDT by Alice0775 White
Modified: 2014-09-28 23:27 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Alice0775 White 2012-11-01 06:30:26 PDT
Build Identifier:
http://hg.mozilla.org/releases/mozilla-release/rev/e0c8343d2809
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0 ID:20121024073032

Steps to reproduce:
1. Open URL http://ricostacruz.com/jquery.transit/
2. Scroll down
3. Mouse hover over examples

Actual results:
Animation does not start
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-11-01 10:28:31 PDT
The library at http://ricostacruz.com/jquery.transit/jquery.transit.js does this:

        var t = $(elem).css('transform') || new Transform();
        t.setFromString(prop, value);

which is, of course, completely broken in any UA that supports unprefixed "transform".
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2012-11-01 10:29:17 PDT
Looks like https://github.com/rstacruz/jquery.transit/issues/86 covers this.
Comment 3 Alice0775 White 2012-11-01 10:31:23 PDT
(In reply to Boris Zbarsky (:bz) from comment #2)
> Looks like https://github.com/rstacruz/jquery.transit/issues/86 covers this.

Thank you for that link
Comment 4 Karl Dubost :karlcow 2014-09-28 23:27:44 PDT
Everything is working for me.

Note You need to log in before you can comment on or make changes to this bug.