Old download window opens when starting download with downloads button invisible.

RESOLVED INVALID

Status

()

Firefox
Downloads Panel
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

Likely a regression from bug 791569. I'll try to add a regression test this time around.
The test collapses the downloads-button-container introduced in bug 803546, so setting the dependency.
Depends on: 803546

Comment 4

5 years ago
See bug 803546 comment 24 as well.
This bug might be invalid - this might be behaviour-by-design.

Discussion ongoing in bug 803546.
Ok, just spoke to shorlander - apparently, this is behaviour by design, and the code I've found is either:

a) Out of date wrt the behaviour spec

or

b) Covers a case I haven't considered.

In either case, I think this bug is now invalid. Thanks for pointing me right, Paolo. :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Attachment #677528 - Attachment is obsolete: true
Attachment #677528 - Flags: review?(mak77)
Comment on attachment 677529 [details] [diff] [review]
Test

I suppose you just forgot to obsolete the attachments.
Attachment #677529 - Attachment is obsolete: true
Attachment #677529 - Flags: review?(mak77)
You need to log in before you can comment on or make changes to this bug.