Closed Bug 807728 Opened 9 years ago Closed 9 years ago

Windowless flash videos no longer display if HA is disabled (No video; only audio)

Categories

(Core :: Graphics: Layers, defect)

19 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla19
Tracking Status
firefox19 + verified

People

(Reporter: fehe, Assigned: karlt)

References

Details

(Keywords: regression)

Attachments

(2 files)

Windowless flash videos no longer display if HA is disabled (No video; only audio).

STR:
1. With a recent m-c Nightly build, set layers.acceleration.disabled to true
2. Initiate playback of any windowless flash video.  For example, videos at nbcnews.com

Regression window: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=76ee46919011&tochange=1ba88bd2f440

Caused by bug 797568
Blocks: 797568
Keywords: regression
You may need to restart the browser after disabling HA.
I'm seeing this too, and I think BetterTouchTool on my Mac is doing something similar to setting layers.acceleration.disabled to true in order to be able to pick up and move Firefox windows - so I don't seem to be able to disable it and get my Flash videos back right now.
For PluginSurfaceParent SurfaceDescriptors at least (don't know about TShmem), the old surface is kept by the PluginSurfaceParent for reuse, so it is not appropriate to call Finish().  This would explain why the plugin is visible for a moment and then disappears.

I wonder why our tests didn't catch this.  Perhaps this is a new drawing model where we are thin on tests.
Attachment #677628 - Flags: review?(roc)
Version: Trunk → 19 Branch
https://tbpl.mozilla.org/?tree=Try&rev=b66e3357b068

https://hg.mozilla.org/integration/mozilla-inbound/rev/1f3ee212a5f2

Looks like reftest unaccelerated opt should catch this with plain old
SharedDIBSurface drawing and at least 3 paints to reuse a front surface after
it becomes a back surface.  I'll look into that.
Flags: in-testsuite?
Sorry, I didn't see that this was WinXP-specific. My comment therefore makes no sense. I'm seeing black in place of flash video on my Retina Mac in current nightlies. Possibly related.
(In reply to Peter Hollo from comment #5)
> Sorry, I didn't see that this was WinXP-specific. My comment therefore makes
> no sense. I'm seeing black in place of flash video on my Retina Mac in
> current nightlies. Possibly related.

I'm not expecting this fix to help any issues on Mac, but probably worth trying Nightly again in a couple of days.  If not, or you are keen to find a regression window now rather than wait, then please file a new bug.
(In reply to Peter Hollo from comment #5)
> Sorry, I didn't see that this was WinXP-specific. My comment therefore makes
> no sense. I'm seeing black in place of flash video on my Retina Mac in
> current nightlies. Possibly related.

I'm seeing both on Windows 7.
Attached file Reduced testcase
https://hg.mozilla.org/mozilla-central/rev/1f3ee212a5f2
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(In reply to Paul [sabret00the] from comment #10)
> This isn't fixed:
> http://www.talksport.co.uk/magazine/virals/121101/video-cazorla-and-arteta-
> mock-man-city-and-wenger-spanish-interview-184375?

It's fixed in the latest Nightly (Built from http://hg.mozilla.org/mozilla-central/rev/2718739a1c83) as the reduced testcase. Be sure you're up-to-date.
3 paints wasn't enough for the test to fail, possibly because of the dummy paint we do on instantiation.  10 is enough, probably more than necessary, but good to know
that 10 paints will be processed.
Bug 810426 covers the test failure (and drawing issues with win7 and accelerated layers).
Tightened up the reftest in https://hg.mozilla.org/integration/mozilla-inbound/rev/da9fc6bdeae0 and re-enabled it in bug 810426.
Flags: in-testsuite? → in-testsuite+
Depends on: 813070
Verified Fixed on FF 19b1 on Windows XP, following STR from Comment 0. I had played different flash videos from www.nbcnews.com with HA disabled and all worked as expected.

Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0(20130109111322)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.