crash in nsINode::OwnerDoc

RESOLVED DUPLICATE of bug 806192

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 806192
5 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

17 Branch
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-d2007a9c-8fab-4bc0-9db8-f178a2121101 .
============================================================= 

Seen while looking at the explosive report today: https://crash-analysis.mozilla.com/rkaiser/2012-10-31/2012-10-31.firefox.17.explosiveness.html

This crash happens in other versions as well, but continues to happen in the 17 betas.

High correlation to Firebug 1.10.5 on the 17 specific crashes:

nsINode::OwnerDoc()|EXCEPTION_ACCESS_VIOLATION_READ (79 crashes)
     94% (74/79) vs.   2% (907/57165) firebug@software.joehewitt.com (Firebug, https://addons.mozilla.org/addon/1843)
     35% (28/79) vs.   0% (285/57165) {c45c406e-ab73-11d8-be73-000a95be3b12} (Web Developer, https://addons.mozilla.org/addon/60)
     30% (24/79) vs.   0% (223/57165) {6AC85730-7D0F-4de0-B3FA-21142DD85326} (ColorZilla, https://addons.mozilla.org/addon/271)
     23% (18/79) vs.   0% (84/57165) {75CEEE46-9B64-46f8-94BF-54012DE155F0} (MeasureIt, https://addons.mozilla.org/addon/539)
     22% (17/79) vs.   2% (1119/57165) OneClickDownload@OneClickDownload.com
     22% (17/79) vs.   4% (2185/57165) {b9db16a4-6edc-47ec-a1f4-b86292ed211d} (Video DownloadHelper, https://addons.mozilla.org/addon/3006)
     20% (16/79) vs.   3% (1562/57165) {CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}
     18% (14/79) vs.   1% (714/57165) gophoto@gophoto.it
     16% (13/79) vs.   0% (28/57165) jid0-lmZNVK7a82O8cufhdfB9dUDfA2w@jetpack
     16% (13/79) vs.   0% (54/57165) jid1-g0J5YenAv9JWlA@jetpack
     15% (12/79) vs.   0% (114/57165) anti_banner@kaspersky.com
     18% (14/79) vs.   4% (2084/57165) {0153E448-190B-4987-BDE1-F256CADA672F}
     15% (12/79) vs.   2% (1023/57165) bbrs_002@blabbers.com
     16% (13/79) vs.   3% (1950/57165) {CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}
     15% (12/79) vs.   3% (1674/57165) {CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA}
     11% (9/79) vs.   0% (22/57165) {BAEBEF65-9289-47c5-8524-C345CC5D860D}
     11% (9/79) vs.   1% (476/57165) anttoolbar@ant.com (Ant.com Toolbar - Tube Downloader, https://addons.mozilla.org/addon/8174)
     16% (13/79) vs.   6% (3393/57165) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
     11% (9/79) vs.   1% (689/57165) {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389} (Download Statusbar, https://addons.mozilla.org/addon/26)
     11% (9/79) vs.   1% (785/57165) {687578b9-7132-4a7a-80e4-30ee31099e03}
     10% (8/79) vs.   0% (70/57165) yslow@yahoo-inc.com (YSlow, https://addons.mozilla.org/addon/5369)
     11% (9/79) vs.   1% (812/57165) {23fcfd51-4958-4f00-80a3-ae97e717ed8b}
     10% (8/79) vs.   1% (400/57165) {46551EC9-40F0-4e47-8E18-8E5CF550CFB8} (Stylish, https://addons.mozilla.org/addon/2108)
     11% (9/79) vs.   2% (1211/57165) {c0c9a2c7-2e5c-4447-bc53-97718bc91e1b} (Easy YouTube Video Downloader, https://addons.mozilla.org/addon/10137)
      9% (7/79) vs.   0% (28/57165) FirePHPExtension-Build@firephp.org (FirePHP, https://addons.mozilla.org/addon/6149)
      9% (7/79) vs.   0% (59/57165) {9c51bd27-6ed8-4000-a2bf-36cb95c0c947} (Tamper Data, https://addons.mozilla.org/addon/966)
     10% (8/79) vs.   2% (978/57165) {e4a8a97b-f2ed-450b-b12d-ee082ba24781} (Greasemonkey, https://addons.mozilla.org/addon/748)
     13% (10/79) vs.   5% (2761/57165) plugin@yontoo.com
      8% (6/79) vs.   0% (15/57165) pixelzoomer@matthiasschuetz.com
      8% (6/79) vs.   0% (196/57165) {37E4D8EA-8BDA-4831-8EA1-89053939A250} (PDF Download, https://addons.mozilla.org/addon/636)
      8% (6/79) vs.   1% (419/57165) DivXWebPlayer@divx.com (DivX Web Player, https://addons.mozilla.org/addon/12938)
      6% (5/79) vs.   0% (8/57165) jid0-hd39BGK3EuIbK47rGW3fZdR163o@jetpack
      6% (5/79) vs.   0% (20/57165) seodoctor@prelovac.com
      6% (5/79) vs.   0% (21/57165) {A0A87DB2-80BA-493a-B22F-FAFBAEA3E0A2} (EditCSS, https://addons.mozilla.org/addon/179)
      6% (5/79) vs.   0% (28/57165) pythonformatters@seleniumhq.org
      6% (5/79) vs.   0% (28/57165) rubyformatters@seleniumhq.org
      6% (5/79) vs.   0% (28/57165) javaformatters@seleniumhq.org
      6% (5/79) vs.   0% (28/57165) csharpformatters@seleniumhq.org
      6% (5/79) vs.   0% (29/57165) {a6fd85ed-e919-4a43-a5af-8da18bda539f} (Selenium IDE, https://addons.mozilla.org/addon/2079)
      6% (5/79) vs.   0% (33/57165) jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack
      6% (5/79) vs.   0% (34/57165) webrank-toolbar@probcomp.com
      6% (5/79) vs.   0% (87/57165) toolbar@alexa.com (Alexa Sparky, https://addons.mozilla.org/addon/5362)
      6% (5/79) vs.   0% (220/57165) {a7c6cf7f-112c-4500-a7ea-39801a327e5f} (FireFTP, https://addons.mozilla.org/addon/684)
     10% (8/79) vs.   4% (2431/57165) {EEE6C361-6118-11DC-9C72-001320C79847}
      9% (7/79) vs.   3% (1842/57165) ffxtlbr@incredibar.com
     99% (78/79) vs.  93% (53226/57165) {972ce4c6-7e08-4474-a285-3208198ce6fd} (Default, https://addons.mozilla.org/addon/8150)
      6% (5/79) vs.   1% (649/57165) {DDC359D1-844A-42a7-9AA1-88A850A938A8} (DownThemAll!, https://addons.mozilla.org/addon/201)
      5% (4/79) vs.   0% (6/57165) showpassword@pratikpoddar (Show Password, https://addons.mozilla.org/addon/10174)
      5% (4/79) vs.   0% (11/57165) resizeit@sonej (ResizeIT, https://addons.mozilla.org/addon/3287)
      5% (4/79) vs.   0% (11/57165) {cf15270e-cf08-4def-b4ea-6a5ac23f3bca} (JSView, https://addons.mozilla.org/addon/2076)
      5% (4/79) vs.   0% (11/57165) {68836a21-fc7d-4ea1-a065-7efabd99d414} (View Source Chart, https://addons.mozilla.org/addon/655)
      5% (4/79) vs.   0% (24/57165) fontfinder@bendodson.com (Font Finder, https://addons.mozilla.org/addon/4415)
      5% (4/79) vs.   0% (30/57165) {cd617372-6743-4ee4-bac4-fbf60f35719e} (Show my Password, https://addons.mozilla.org/addon/8016)

Version specific:

nsINode::OwnerDoc()|EXCEPTION_ACCESS_VIOLATION_READ (79 crashes)
     94% (74/79) vs.   2% (907/57165) firebug@software.joehewitt.com (Firebug, https://addons.mozilla.org/addon/1843)
          0% (0/79) vs.   0% (5/57165) 1.10.0
          0% (0/79) vs.   0% (3/57165) 1.10.2
          0% (0/79) vs.   0% (6/57165) 1.10.3
          6% (5/79) vs.   0% (61/57165) 1.10.4
         86% (68/79) vs.   1% (728/57165) 1.10.5
          1% (1/79) vs.   0% (77/57165) 1.10.6
          0% (0/79) vs.   0% (1/57165) 1.11.0a4
          0% (0/79) vs.   0% (8/57165) 1.11.0a5
          0% (0/79) vs.   0% (2/57165) 1.6X.1b2
          0% (0/79) vs.   0% (1/57165) 1.7.2
          0% (0/79) vs.   0% (5/57165) 1.8.4
          0% (0/79) vs.   0% (10/57165) 1.9.2



Frame 	Module 	Signature 	Source
0 	xul.dll 	nsINode::OwnerDoc 	obj-firefox/dist/include/nsINode.h:427
1 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1092
2 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
3 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
4 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
5 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
6 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
7 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
8 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
9 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
10 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
11 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
12 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
13 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
14 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
15 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
16 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
17 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
18 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
19 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
20 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
21 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
22 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
23 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
24 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1574
25 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
26 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
27 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
28 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
29 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
30 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
31 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1595
32 	xul.dll 	nsFrameManager::ComputeStyleChangeFor 	layout/base/nsFrameManager.cpp:1686
33 	xul.dll 	mozilla::css::RestyleTracker::ProcessOneRestyle 	layout/base/RestyleTracker.cpp:124
34 	xul.dll 	mozilla::css::RestyleTracker::DoProcessRestyles 	layout/base/RestyleTracker.cpp:209
35 	xul.dll 	nsCSSFrameConstructor::ProcessPendingRestyles 	layout/base/nsCSSFrameConstructor.cpp:12075
36 	xul.dll 	PresShell::FlushPendingNotifications 	layout/base/nsPresShell.cpp:3856
37 	xul.dll 	nsDocument::FlushPendingNotifications 	content/base/src/nsDocument.cpp:6360
38 	xul.dll 	nsComputedDOMStyle::GetPropertyCSSValue 	layout/style/nsComputedDOMStyle.cpp:447
39 	xul.dll 	nsComputedDOMStyle::GetPropertyValue 	layout/style/nsComputedDOMStyle.cpp:256
40 	xul.dll 	nsICSSDeclaration::GetPropertyValue 	layout/style/nsICSSDeclaration.h:111
41 	xul.dll 	mozilla::dom::CSSStyleDeclarationBinding::getPropertyValue 	obj-firefox/dom/bindings/CSSStyleDeclarationBinding.cpp:129
42 	xul.dll 	mozilla::dom::CSSStyleDeclarationBinding::genericMethod 	obj-firefox/dom/bindings/CSSStyleDeclarationBinding.cpp:325
43 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:352
44 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2414
45 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:363
46 	mozjs.dll 	js::Invoke 	js/src/jsinterp.h:119
47 	mozjs.dll 	js::CallOrConstructBoundFunction 	js/src/jsfun.cpp:1039
48 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:352
49 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2414
50 	mozjs.dll 	js::types::TypeSet::addType 	js/src/jsinferinlines.h:1260
51 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:363
52 	mozjs.dll 	js::Invoke 	js/src/jsinterp.h:119
53 	mozjs.dll 	js::CallOrConstructBoundFunction 	js/src/jsfun.cpp:1039
54 	mozjs.dll 	js::mjit::CallCompiler::generateNativeStub 	js/src/methodjit/MonoIC.cpp:776
55 	mozjs.dll 	js::mjit::ic::NativeCall 	js/src/methodjit/MonoIC.cpp:1009
56 	mozjs.dll 	js::mjit::Compiler::performCompilation 	js/src/methodjit/Compiler.cpp:531
57 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2454
58 	mozjs.dll 	proxy_GetGeneric 	js/src/jsproxy.cpp:1510
59 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:363
60 	mozjs.dll 	js::Invoke 	js/src/jsinterp.h:119
61 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:912
62 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:352
63 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2414
64 	mozjs.dll 	js::types::TypeSet::addType 	js/src/jsinferinlines.h:1269
65 	plds4.dll 	PL_HashTableAdd 	nsprpub/lib/ds/plhash.c:264
66 	mozjs.dll 	js::Invoke 	js/src/jsinterp.h:119
67 	mozjs.dll 	js::CallOrConstructBoundFunction 	js/src/jsfun.cpp:1039
68 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:352
69 	mozjs.dll 	js::Invoke 	js/src/jsinterp.h:119
70 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:912
71 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:352
72 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2414
73 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:363
74 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:396
75 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5846
76 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1918
77 	xul.dll 	nsGlobalWindow::RunTimeoutHandler 	dom/base/nsGlobalWindow.cpp:9612
78 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9863
79 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:10130
80 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:473
81 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
82 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
83 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
84 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
85 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
86 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:232
87 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:273
88 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3812
89 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3889
90 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3965
91 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:100
92 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
93 	kernel32.dll 	BaseProcessStart

Comment 1

5 years ago
Most stack traces look like:
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsINode::OwnerDoc 	obj-firefox/dist/include/nsINode.h:427
1 	xul.dll 	inDOMUtils::GetBindingURLs 	layout/inspector/src/inDOMUtils.cpp:248
2 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:70
3 	xul.dll 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:2406
4 	xul.dll 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1478
5 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:352
6 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2414
...
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806192
You need to log in before you can comment on or make changes to this bug.