Only enable OMTC for certain platforms

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jdm, Assigned: jdm)

Tracking

unspecified
x86_64
Linux
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Currently b2g.js unconditionally enables OMTC. This is bad for local desktop builds, and possibly desktop nightlies. We should disable it at least for Windows, where I've seen it cause startup crashes.
(Assignee)

Comment 1

5 years ago
Created attachment 677525 [details] [diff] [review]
Disable OMTC in b2g builds on Windows.
Attachment #677525 - Flags: review?(jones.chris.g)
(Assignee)

Updated

5 years ago
Assignee: nobody → josh
(Assignee)

Updated

5 years ago
Blocks: 795484
In my testing, disabling OMTC on Windows does enable B2G to start up without crashing, but it has a couple side-effects: the B2G wallpaper is replaced by a black background; and a mouse click-and-drag, which simulates a finger swipe on an actual device, doesn't cause a repaint until the next event is dispatched.
Comment on attachment 677525 [details] [diff] [review]
Disable OMTC in b2g builds on Windows.

You can drop the #else because this defaults to false.  Please link a FIXME/bug XXXXX in a comment here.

r=me with that
Attachment #677525 - Flags: review?(jones.chris.g) → review+
(Assignee)

Comment 4

5 years ago
Chris, should this be disabled for desktop builds in general, since it's a fairly unsupported setup at this point? Are we able to differentiate between device and desktop builds?
It's also disabled on x11 builds, although that's not obvious from the pref.  (x11 is a special snowflake.)

My understanding is that omtc on mac is pretty stable, but I don't use a mac so I don't have firsthand evidence.  CC'ing some folks who know better.
I ran OMTC mac build by default for daily browsing for about a month where it was stable minus a few buffer rotation bugs. And if it isn't then we've got a regression on our hands.

Comment 7

5 years ago
OMTC mac is fine right now, at least for casual browsing (I'm not using it full time, but I haven't seen it crash or mis-render for a long time).
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/12ac23e3c313 and comment followup in https://hg.mozilla.org/integration/mozilla-inbound/rev/49e7c88df185.
(Assignee)

Comment 9

5 years ago
Comment on attachment 677525 [details] [diff] [review]
Disable OMTC in b2g builds on Windows.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Startup crashes for windows b2g desktop builds.
Testing completed (on m-c, etc.): Multiple b2g desktop builds across several machines that did not start and now do.
Risk to taking this patch (and alternatives if risky): The risk of shipping a desktop build that is actually usable.
String or UUID changes made by this patch: None.
Attachment #677525 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #677525 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/12ac23e3c313
https://hg.mozilla.org/mozilla-central/rev/49e7c88df185
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed for aurora]
https://hg.mozilla.org/releases/mozilla-aurora/rev/c8a04a9e8a3f
https://hg.mozilla.org/releases/mozilla-aurora/rev/76e2abf198c0
status-firefox18: --- → fixed
status-firefox19: --- → fixed
Keywords: checkin-needed
Whiteboard: [checkin-needed for aurora]
You need to log in before you can comment on or make changes to this bug.