Open Bug 807762 Opened 7 years ago Updated 26 days ago

Selection handles and selection disappears when choosing "Select All" from the context menu for text controls

Categories

(Firefox for Android :: Text Selection, defect, P5)

All
Android
defect

Tracking

()

REOPENED
Tracking Status
fennec ? ---
firefox-esr68 --- affected
firefox62 --- affected
firefox63 --- affected
firefox64 --- affected
firefox65 --- affected
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

Steps to reproduce:
- Visit http://people.mozilla.org/~mwargers/tests/forms/textinput/609940_textarea.html
- Long tap on a textarea to get the context menu
- Tap on "Select All"


Expected result:
- All text selected in textarea and selection handles appearing at the right spot

Actual result:
- Text selection and selection handles appear briefly, but disappear as soon as the vkb has arrived.

Tested on the Galaxy Nexus, using latest trunk build.

I'm assuming this is a regression from bug 652168, but I might be wrong, since this is about selection handles, and that bug is about thumb controls.
I don't know why we dismiss the text selection handlers when VKB comes up (which causes page shrinking). Margaret might know it better as she worked on it a lot.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Attached image Screenshot
Devices: LG G4 (Android 6.0.1), Xiaomi Mi4i (Android 5.0.2).

STR: 
1. Open a site ex: https://en.wikipedia.org/wiki/Mozilla.
2. Tap press-hold on a selected word such as: 'Mozilla'.
3. Choose "Select All"

Expected result:
All text from the page is selected and the handles selection bars are on the proper position.

Actual result:
The selection handle bar from top it's on wrong position from text. The selection handle bar from bottom it's missing.

Notes:
On some pages the selection handle bar from top it's missing and the selection handle bar from bottom it's on wrong position from text.
tracking-fennec: --- → ?
Component: Keyboards and IME → Text Selection
OS: Windows 7 → Android
Hardware: x86 → ARM
Version: unspecified → Trunk
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5
Hardware: ARM → All

Hi, issue reproduces on Firefox Release 68.1.1, Firefox Beta 68.2b4 and Firefox Nightly 68.2a1(2019-09-23) from playstore.
I will change the status-firefox-esr68 to affected.
Both top and bottom handles are missing when "Select All" option is chosen.

You need to log in before you can comment on or make changes to this bug.