Last Comment Bug 807850 - Add a memory reporter for the nsScriptNameSpaceManager
: Add a memory reporter for the nsScriptNameSpaceManager
Status: RESOLVED FIXED
[MemShrink]
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla19
Assigned To: Nicholas Nethercote [:njn] (on vacation until July 11)
:
Mentors:
Depends on:
Blocks: B2GDarkMatter
  Show dependency treegraph
 
Reported: 2012-11-01 16:38 PDT by Nicholas Nethercote [:njn] (on vacation until July 11)
Modified: 2013-01-14 06:37 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Add a memory reporter for the nsScriptNameSpaceManager. (6.57 KB, patch)
2012-11-01 16:39 PDT, Nicholas Nethercote [:njn] (on vacation until July 11)
jst: review+
bajaj.bhavana: approval‑mozilla‑aurora+
Details | Diff | Review

Description Nicholas Nethercote [:njn] (on vacation until July 11) 2012-11-01 16:38:50 PDT
This is one of the bigger single chunks remaining, and it shows up in every
process on B2G.
Comment 1 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-11-01 16:39:13 PDT
Created attachment 677608 [details] [diff] [review]
Add a memory reporter for the nsScriptNameSpaceManager.

Pretty straightforward.  On 64-bit builds it's 153 KiB per process, and
probably a bit less on 32-bit.
Comment 2 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-11-01 16:45:11 PDT
> Pretty straightforward.  On 64-bit builds it's 153 KiB per process, and
> probably a bit less on 32-bit.

For the main process that is ~0.5% of the heap, for child processes it's ~1%.
Comment 3 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-11-04 14:58:34 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a5775d8c498
Comment 4 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-11-04 15:01:10 PST
Comment on attachment 677608 [details] [diff] [review]
Add a memory reporter for the nsScriptNameSpaceManager.

[Approval Request Comment]

Bug caused by (feature/regressing bug #):  N/A.

User impact if declined:  less understanding of B2G memory consumption.

Testing completed (on m-c, etc.):  just landed on m-c.

Risk to taking this patch (and alternatives if risky):  minimal.  Code is only run when viewing about:memory or triggering a memory report dump.

String or UUID changes made by this patch:  none.
Comment 5 Ed Morley [:emorley] 2012-11-05 07:50:06 PST
https://hg.mozilla.org/mozilla-central/rev/5a5775d8c498
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-11-07 18:54:57 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/8ae22fe748fc
Comment 7 Mihai Morar, (:MihaiMorar) 2013-01-14 06:37:30 PST
Can someone please attach a testcase ?

Note You need to log in before you can comment on or make changes to this bug.