If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

onfocus in body tag can cause infinite loop

RESOLVED DUPLICATE of bug 58441

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 58441
17 years ago
15 years ago

People

(Reporter: Ryan MacLachlan, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
A script such as this
<BODY onfocus="alert('la la la')">
causes Mozilla to lock up until i kill the process!

Comment 1

17 years ago
Created attachment 34419 [details]
HTML testcase

Updated

17 years ago
Assignee: rogerl → joki
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Event Handling
Ever confirmed: true
QA Contact: pschwartau → gerardok

Comment 2

17 years ago
Browser, not engine. Reassigning to Event Handling for further triage.

Comment 3

17 years ago
IE4.7 does not go into an infinite loop on the testcase. 

NN4.7 goes into an infinite loop if you load the testcase, Alt+Tab to 
some other application, then Alt+Tab back to NN4.7

Moz also infinite-loops, if you bring the mouse to focus on the body -
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 58441 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.