Add memory reporters for nsComponentManager and nsCategoryManager

RESOLVED FIXED in Firefox 18

Status

()

Core
XPCOM
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
mozilla19
Points:
---

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed)

Details

(Whiteboard: [MemShrink])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
nsComponentManager and nsCategoryManager account for a moderate amount of memory in each B2G process.
(Assignee)

Comment 1

5 years ago
Created attachment 677646 [details] [diff] [review]
(part 1) - Remove dead nsComponentManagerImpl::mLoaderData.

Simple dead code removal.
Attachment #677646 - Flags: review?(benjamin)
(Assignee)

Comment 2

5 years ago
Created attachment 677647 [details] [diff] [review]
(part 2) - Add memory reporters for nsComponentManager and nsCategoryManager.

These reporters account for about 270 KiB per process on 64-bit builds.
Attachment #677647 - Flags: review?(benjamin)
(Assignee)

Comment 3

5 years ago
Review ping.  Getting "heap-unclassified" down is quite important for B2G, and this is one of the larger pieces left.

Updated

5 years ago
Attachment #677646 - Flags: review?(benjamin) → review+

Updated

5 years ago
Attachment #677647 - Flags: review?(benjamin) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/47b21acef98e
https://hg.mozilla.org/integration/mozilla-inbound/rev/74a7026fff15
https://hg.mozilla.org/mozilla-central/rev/47b21acef98e
https://hg.mozilla.org/mozilla-central/rev/74a7026fff15
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(Assignee)

Comment 6

5 years ago
Comment on attachment 677646 [details] [diff] [review]
(part 1) - Remove dead nsComponentManagerImpl::mLoaderData.

[Approval Request Comment]

Bug caused by (feature/regressing bug #):  N/A.

User impact if declined:  prevents the next patch from applying.

Testing completed (on m-c, etc.):  been on m-c for several days without problem.

Risk to taking this patch (and alternatives if risky):  negligible;  it's trivial dead code removal.

String or UUID changes made by this patch:  none.
Attachment #677646 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 7

5 years ago
Comment on attachment 677647 [details] [diff] [review]
(part 2) - Add memory reporters for nsComponentManager and nsCategoryManager.

[Approval Request Comment]

Bug caused by (feature/regressing bug #):  N/A.

User impact if declined:  less understanding of B2G memory consumption.

Testing completed (on m-c, etc.):  been on m-c for several days.

Risk to taking this patch (and alternatives if risky):  low.  The code is only run when about:memory is viewed or a memory reporter dump is triggered.

String or UUID changes made by this patch:  none.
Attachment #677647 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #677646 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Attachment #677647 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/f5f84571a165
https://hg.mozilla.org/releases/mozilla-aurora/rev/8947bfd8f678
status-firefox18: --- → fixed
status-firefox19: --- → fixed
You need to log in before you can comment on or make changes to this bug.