Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Change/onchange event on select element was not triggered at correct timing

RESOLVED DUPLICATE of bug 126379

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 126379
5 years ago
4 years ago

People

(Reporter: byzod, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 677728 [details]
test case and short description inside

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121002073616

Steps to reproduce:

Bind some noticeable function (e.g. alert(1)) to combobox

Click on the combobox(select element) once, then click anywhere else to give the focus to it, but not make any choice, then change the selected item with keyboard arrow keys (up and down), check if the function you just bind was triggered.

Click somewhere else again to release the focus, check what happened.



Actual results:

When change options with arrow keys, the change event is not triggered.

When release the focus, event was triggered, i.e. it was triggered at when the blur/onblur event was fired.


Expected results:

IE9 and Chrome 23 fired the change event at right time (when you change options with arrow keys). Firefox should, too.

Updated

5 years ago
Attachment #677728 - Attachment mime type: text/plain → text/html
I'm pretty sure this is a duplicate of an old issue. Something like bug 126379.
Component: Untriaged → DOM: Events
Product: Firefox → Core
Whiteboard: dupeme
(Reporter)

Comment 2

5 years ago
(In reply to Virgil Dicu [:virgil] [QA] from comment #1)
> I'm pretty sure this is a duplicate of an old issue. Something like bug
> 126379.

Jesus! It's from '60s! Well, I mean this bug was there for 10 years, why firefox never fix it? The W3 clearly declared that onChange event should be triggered with keyboard: [1]Procedure: 1. Using the keyboard or an assistive technology that emulates the keyboard, move focus to the select control.  2.Using the keyboard or an assistive technology that emulates the keyboard, select a value from the menu to trigger the onChange event.


  [1]]http://www.w3.org/WAI/UA/TS/html401/cp0102/0102-ONCHANGE-SELECT.html

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 126379
You need to log in before you can comment on or make changes to this bug.