Closed Bug 808042 Opened 9 years ago Closed 9 years ago

Build broken in dom/system/OSFileConstants.cpp

Categories

(Toolkit :: OS.File, defect)

All
FreeBSD
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 817267

People

(Reporter: mpk, Unassigned)

References

Details

(Keywords: regression)

Recent trunk builds are broken on FreeBSD (maybe other unices are affected as well).
I suspect the error was introduced with the patch for bug 770538. The error thrown is:

[ ... ]
gmake[6]: Entering directory `/mnt/build/dom/system'
OSFileConstants.cpp
nsIOSFileConstantsService.idl
/mnt/src/mozilla/dom/system/OSFileConstants.cpp:388:47: error: no member named
      '__dd_fd' in '_dirdesc'
  { "OSFILE_OFFSETOF_DIR_DD_FD", INT_TO_JSVAL(offsetof (DIR, __dd_fd)) },
                                              ^~~~~~~~~~~~~~~~~~~~~~~
/usr/include/stddef.h:62:32: note: expanded from macro 'offsetof'
#define offsetof(type, member)  __offsetof(type, member)
                                ^
/usr/include/sys/cdefs.h:391:34: note: expanded from macro '__offsetof'
#define __offsetof(type, field)  __builtin_offsetof(type, field)
                                 ^                        ~~~~~
1 error generated.

In the directory  /mnt/build/dom/system
The following command failed to execute properly:
clang++ -o OSFileConstants.o [ ... ] /mnt/src/mozilla/dom/system/OSFileConstants.cpp
gmake[6]: *** [OSFileConstants.o] Error 1
gmake[6]: Leaving directory `/mnt/build/dom/system'
gmake[5]: *** [system_libs] Error 2
gmake[5]: *** Waiting for unfinished jobs....
[ ... ]
Component: Networking: File → OS.File
Product: Core → Toolkit
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 817267
You need to log in before you can comment on or make changes to this bug.