Closed Bug 808110 Opened 7 years ago Closed 7 years ago

No HTTP Traffic is being seen fired for stub installer pings when installing Firefox

Categories

(Firefox :: Installer, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox17 --- unaffected
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: jsmith, Assigned: bbondy)

References

Details

(Whiteboard: [stub+])

Attachments

(1 file)

Followup to bug 802734 - While running a HTTP Debugging Proxy (e.g. Fiddler, Wireshark), I am not seeing any activity that indicates that a ping is being fired by the stub installer during the installation process. Throughout the entire process in Fiddler, the following is only see in the logs:

GET http://download.mozilla.org/?product=firefox-nightly-latest&os=win&lang=en-US
302 Found to http://wpc.1237.edgecastcdn.net/801237/download.cdn.mozilla.net/pub/mozilla.org//firefox/nightly/latest-mozilla-central/firefox-19.0a1.en-US.win32.installer.exe

GET http://wpc.1237.edgecastcdn.net/801237/download.cdn.mozilla.net/pub/mozilla.org//firefox/nightly/latest-mozilla-central/firefox-19.0a1.en-US.win32.installer.exe
200 OK (application/octet-stream) 

The above logs indicate that the stub is successfully pulling down the stub bits, but there's no evidence of anything that looks like a ping to a metrics server.
Blocks: 802734
Version: unspecified → Trunk
Whiteboard: [stub+]
Hey Brian - would be great if you could take a look today. Even better would be if we could try to get a fix out today/tomorrow.
Assignee: nobody → netzen
Yup I'm on it. The bug is in the original patch.  For the checkbox I only tested to make sure the original code would be hit, which it is.
So basically the bug was that we were passing way too many parameters to the InetBG plugin.  Adjoining strings (even if separated with a \) are treated as different parameters, unlike in c++.


[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 802734, original patch
User impact if declined: Pings will never be sent. I didn't notice the problem when I reviewed the patch :(
Testing completed (on m-c, etc.): No, but I tested locally
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: none
Attachment #677845 - Flags: review?(jmathies)
Attachment #677845 - Flags: approval-mozilla-aurora?
Attachment #677845 - Flags: review?(jmathies) → review+
http://hg.mozilla.org/mozilla-central/rev/27db7a7e3e15
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Keywords: verifyme
QA Contact: jsmith
I verified this patch locally with wireshark btw and I seen the ping go by.
Attachment #677845 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
QA Contact: jsmith
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.