High quality image resizing artifacts on fractionally sized images

RESOLVED DUPLICATE of bug 804559

Status

()

defect
RESOLVED DUPLICATE of bug 804559
7 years ago
6 years ago

People

(Reporter: bugzmailer, Assigned: joe)

Tracking

({regression})

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox18 unaffected, firefox19 affected)

Details

Attachments

(2 attachments)

192.57 KB, application/octet-stream
Details
316.82 KB, image/png
Details
(Reporter)

Description

7 years ago
See testcase. The images are getting fractional heights. When image.high_quality_downscaling.enabled is true, the last row of the second image is wrong (looks like a duplicate of the first row). Probably some rounding issue somewhere.
(Reporter)

Comment 1

7 years ago
Posted file testcase

Updated

7 years ago
Blocks: 486918
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Could you post your about:support graphics section here?

Comment 3

7 years ago
Posted image screenshot
This problem happens REGARDLESS of HWA enabled/Disabled.

Graphics
Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50
Device ID: 0x954f
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.17789)
Driver Date: 7-3-2012
Driver Version: 8.970.100.3000
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series)
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo

Comment 4

7 years ago
I think this also related to Bug 804559

Comment 5

7 years ago
And this also happens on Linux.
http://hg.mozilla.org/mozilla-central/rev/2718739a1c83
Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/19 Firefox/19.0a1 ID:20121103030715

Graphics 
Adapter Description : VMware, Inc. -- Gallium 0.4 on SVGA3D; build: RELEASE;  
Device ID : Gallium 0.4 on SVGA3D; build: RELEASE;  
Driver Version: 2.1 Mesa 8.0.4
GPU Accelerated Windows: 0/1 Basic 
Vendor ID: VMware, Inc.
WebGL Renderer: VMware, Inc. -- Gallium 0.4 on SVGA3D; build: RELEASE;  
AzureCanvasBackend: cairo
AzureContentBackend: none
AzureFallbackCanvasBackend: none
OS: Windows 7 → All
(Reporter)

Comment 6

7 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #2)
> Could you post your about:support graphics section here?

As Alice said it doesn't really matter, I've seen it on several machines and without HW accel and it always looks the same.

Completely wild guess about what is going on: the images are getting a height of 435.367px. The HQ resizer thinks that's 435px, and so prepares a image of that size. However layout keeps the fractional part, and an image can end up starting at .367 and ending at .734. The first rounds down and the second up, so the image ends up being 436px tall. The last row is then filled incorrectly.
We'll track this for release, but likely would not block a release on this issue.

Comment 8

7 years ago
Lnading of Bug 486918 causes this problem

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ff86ec766232
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121001112917
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c0873dd40e2d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121001115917
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ff86ec766232&tochange=c0873dd40e2d

Regressed by Bug 486918
Updating keywords as per comment 8.
Keywords: qawantedregression
(Assignee)

Comment 10

7 years ago
Thanks for the great bug report! I'm happy to say that this is fixed by my patch in bug 804559, so I'm just duplicating this off.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804559
You need to log in before you can comment on or make changes to this bug.