Quick edit not working on IPB 2.x

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
5 years ago
a year ago

People

(Reporter: Strahinja Kustudic, Unassigned, NeedInfo)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121031065642

Steps to reproduce:

On site http://www.gamereplays.org/ which uses IPB 2.0.X for forums, since the update to 17 beta, quick edit hasn't been working. I tried disabling all addons, I tried creating a fresh new profile with no addons and quick edit still didn't work. It works without a problem in FF 16.

To reproduce this bug, you need to:
1. register an account on http://www.gamereplays.org/community/index.php?act=Reg&CODE=00
2. once registered go into e.g. New Members forum http://www.gamereplays.org/community/index.php?showforum=7
3. create a new topic and submit it
4. now while viewing your post, click on the Edit button.

In FF 16 and earlier this works without any problems.



Actual results:

A new page loads to edit that post.


Expected results:

A small popup should come up allowing you to chose between Quick Edit and Full Edit.

Comment 1

5 years ago
Because the website is doing bad UA sniffing. If you spoof the UA (to be Chrome e.g.), it works fine, you're able to see the small pop-up with "Quick Edit" and "Full Edit".

It's due to bug 588909 that was in FF15/16 nightlies but has been backout.
Assignee: nobody → english-us
Blocks: 588909
Status: UNCONFIRMED → NEW
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
Component: Untriaged → English US
Ever confirmed: true
Keywords: regression
Product: Firefox → Tech Evangelism
Version: 17 Branch → unspecified

Comment 2

5 years ago
For the record, use this test account:
U: bmo
P: azerty
Press "edit" on this thread:
http://www.gamereplays.org/community/index.php?showtopic=906601
I don't think we need to track this, since (1) IPB thankfully falls back to loading the standard editing page and (2) this needs to be fixed on their side.
tracking-firefox17: ? → ---
tracking-firefox18: ? → ---
tracking-firefox19: ? → ---
(Reporter)

Comment 4

5 years ago
Thanks for the clarification.
(In reply to Loic from comment #2)
> For the record, use this test account:
> U: bmo
> P: azerty
> Press "edit" on this thread:
> http://www.gamereplays.org/community/index.php?showtopic=906601

"Your trial subscription has ended" :-|

Gerv

Comment 6

5 years ago
The account works here, I'm able to log in and post.
Anyway, it's a free board, just create a test account, it takes 1 min.
(Reporter)

Comment 7

5 years ago
The trial is just for no ads trial, nothing more. The site is 100% free.

Comment 8

5 years ago
Hello,

excuse my English i'm French man.

I have the same error exactly, my shoutbox shows nothing more and my quick edition does not work any more 

my site run in ipb v2.2.2

this will be you it corrected in a next version or not? (v17.X ? or v18 ?)

with FF 16 and earlier no probleme

it is a pity that firefox is not compatible any more with all Websites!

Comment 9

5 years ago
There is nothing to fix in next versions of Firefox, it's a website issue that applies bad user agent sniffing.
Read the whole bug report, all is explained.

Comment 10

5 years ago
I have resolut the probleme to employ user agent switcher 

but I not understand why has the 17th version firefox decide to change the manner of managing to user agent

what mean that everything the users ip.board v2.2. X have to close their forum?!

firefox is not any more compatible 100 % what is discouraging...

thanks for your help by ;)

Comment 11

5 years ago
UA changes should be backout in a chemspill release 17.0.1, see bug 815743.
Is it still an issue?
Assignee: english-us → nobody
Component: English US → Desktop
Flags: needinfo?(kustodian)
The footer displays
© 2016 GameReplays.org -- Invision Power Board © 2016 IPS, Inc. Licensed to: GameReplays.org 

The latest version is 4.1.14.2
https://invisionpower.com/https://invisionpower.com/release-notes/41142-r49/?do=getLastComment

I do not have an account on GameReplays.org but I would imagine it has been fixed. 
If you find the issue is still here, feel free to reopen this issue.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.